How to share one phone with two extension numbers and distinct ring

Currently using Asterisk 1.4 and freepbx 2.3, all working fine for my little home system for the family, I’m using a linksys PAP2 and have created two extensions 303 for the kids and 302 for the parents, have setup a nice IVR so that when you call it sais dial 1 for the kids (Rachel or Judith) or 2 for the parents (Louis or Josee).

This all works fine, and I want to say thank you to all at FrePBX and Asterisk for the great initiative.

Things change in life, and at the beggining of the year 2009 me and my wife seperated, so I created a seperate extension 304 for Josee, I have it ring the same phone (SIP/302) as for my extention, so if no one is home it works fine, she has a personal voice mail sent to her personal email, but if I’m home I pick up the phone, and I have no way of knowing (except a quick glimpse at the caller id and a fast guess) if the user dialed 302 or 304, if I could set a distinctive ring on 304 I could know it’s for her and just let it ring, if she’s home (she does still come in on weekends some times) she could pick it up.

I am able to change the ring on the PAP2 by using Bellcore-r2 in alert info fileld but I have to do that throught the incomming trunk, so it does not work for my need. I tried this in extensions_custom.conf; (added at the end of the file)

exten => 304,1,NoOp(Setting_ainfo)
exten => 304,n,SIPAddHeader(Alert-Info:;info=Bellcore-r2))
exten => 304,n,Goto(ext-local,304,1)

but the system seems to ignore my change. Any clues suggestions would be very appreciated. Many thanks, LD

Is that everything you added to the extensions_custom.conf? If so that would be why. It needs to be under a specific context to work and currently it’s under what ever context was found previous to reading those lines.

Let’s see if I remember this correctly as I don’t ahve access to my system currently.

The best bet is to create a custom context name like [Josee-call] then when they call in for that extension have it refer to that context, it will set what you did above and then you have it forwarding on like normal.

When I get back to my office (and if I remember) I’ll but it up with details and update this posting.

Here is my file (I have removed a lot of commented lines) - I did not change the context of extension 304 (from-internal) - Thx - LD

; This file contains example extensions_custom.conf entries.
; extensions_custom.conf should be used to include customizations
; to AMP’s Asterisk dialplan.

; All custom context should contain the string ‘custom’ in it’s name

; Extensions in AMP have access to the ‘from-internal’ context.
; The context ‘from-internal-custom’ is included in ‘from-internal’ by default

#include extensions_trixbox.conf
#include extensions_hud.conf

[from-internal-custom]

include => from-internal-trixbox

exten => 304,1,NoOp(Setting_ainfo)
exten => 304,n,SIPAddHeader(Alert-Info:;info=Bellcore-r2)
exten => 304,n,Goto(ext-local,304,1)

People so overlook the power of Follow-Mes - note that among other options that would be useful in your situation, there’s a text field to specifically set the Alert Info, which is what you want. Remember you don’t actually have to put more than one extension in the Follow-Me List. So make a Follow-Me for 304, point it to 302 in the Follow-Me List (so only that extension rings, if that is what you want) and then put your Bellcore-r2 in the Alert Info, and set the destination if no answer to her voicemail and that should do it!

Hello,

Many thanks for your solution, much simpler than fidling with files and worked like a charm - Thank you, good day, LD