How to set Caller ID when forwarding an extension to an external number?

Please advise,

When I use call forwarding unconditional on an extension, the original ingress callerid is being passed instead of the extension number on an external call.

I’ve set the extension Outbound CID field to:

“caller name” <9491234567>

I’ve set the trunk CID options to: Allow any CID

Do I have a syntax issue with the Outbound CID?



I have the same problem, but my transfered calls always end up as private nrs.
Did you register your voip nr at your sip trunk provider? (I did, but still no joy)

when a call is forwarded, it uses the original callers number unless you block that in the trunk.

If blocked in the trunk, the fallback will be the trunk CID, not the extension’s CID.

If you want to set the CID on a “forwarded” call you will need to use either a Follow-Me or Ring Group and use the options towards the bottom that let you modify the outbound CID on external calls.

Oh, so the Extension Outbound CID only applies on follow-me or ring groups?




the extension Outbound CID only applies when that extension originates an outbound call, and nothing overrides that CID which is usually the case.

Awesome! Got it working! Thx so very much! -Paul