How to remove "You have an incoming call" message on call forwarded out to external number


FreePBX 2.8.14, Core 2.8.12, everything else is pretty much upto the latest patch.

Situation is that we want to forward any calls into the main trunk out to an external number outside of office hours. The good news is that the details to achieve this were all on the forums so thank you for that!

So the incoming route has a destination of a time condition which then redirects the call to a ring group containing an external number. All this works fine with one small exception…

If the destination external number is set to my mobile then it works perfectly. But if I direct to a local external number ( which is what 1 want to do ) the person receiving the call gets a “You have an incoming call” message. If they then press 1 the call is connected.

The final twist is that if I call the number directly from a phone registered to the freePBX system then the call goes through perfectly.

I need to know how and where this message has crept into my configuration and more importantly how the heck to get rid of it!

I’ve fiddled around with the settings quite a bit but this is what it is right now…

Trunk - allow any CID, one dialed number rule for local calls
Outbound Route - Permanent Route, Dial pattern of 1|.
Inbound Route - No DID or caller ID numbers, No CID lookup, Destination = time condition
Time condition - Simple office hours schedule, ring reception extn in office hours or a ring group outside those hours.
Ring Group - RingAll, 1numberhere#, Ring, Confirm Calls, Default CID, Hangup call on no answer.

Any ideas anyone?

Many Thanks


Ahh Ha!

I need to type out my configuration more often. When I re-read it the Confirm Calls jumped out at me - with that removed and the destination number in the call group stripped of it’s area code ( it’s a local number ) the forward worked as expected.

Hopefully this might save someone half an hours head scratching later on!