How to override from-sip-external

Every day I get anonymous SIP calls. I would like to simply hang up instead of playing ss-noservice and congestion, which is the default. How can I override the from-sip-external context? I only see it referenced in two files and don’t see how I can override either without FreePBX overwriting my changes.

x:/etc/asterisk $ grep ‘from-sip-external’ *


Why are you exposing your box to the outside world ???
Have looked at the allowguest setting ?

Because it’s used to make calls to and from the outside world. Isn’t that typical?

This thread says that allowguest is not used:

Looks like somebody missed or was asleep during Networking 101 :wink:

What does that mean? Do you have a suggestion for resolving the problem?

Thanks for being a dick, obelisk. Many servers are on the edge to avoid all of the NAT hassles. I read about it being a recommended configuration all of the time, as long as iptables and fail2ban are set up correctly. For example, if you use NAT, you can’t back up from one server and restore it on another because the network settings are in the backup.