How to make an external call using a custom extentions?


i’m having some issue that i can figure it out, we have a customer that had SIP trunking before now they move to a PRI/TI service, so we are using DAHDI, the issue is that when they are closed we have a Custom Extension using custom technologies to dial an external number true the IVR.

the dial string is: SIP/TRUNKNAME/NNNNNNNN(number)

i’m trying to set this dial string using DAHDI but not such luck.

i’ve used DAHDI/g0/NNNNNNNNNN also local/[email protected]

and nothing i know that you guys have done this million of time or there is another way to set an option on an IVR to call an external number?

Thanks in advance.

In Misc Destinations Type name of Destination (Divert After Hours) and then type the number you want to dial (as if you were dialing it from a handset). Then in the IVR, make the option for whatever number to be the Misc Destination you just made.
Works for me :slight_smile:

it says “we are sorry but the call did not complete as dial”

i can see in the CLI that is dialing out the number but dont know what i, getting this messages

here is the CLI result:


Executing [[email protected]:20] Dial(“DAHDI/8-1”, “DAHDI/g0/1757606XXXX|300|M(setmusic^NYCenter)”) in new stack
– Requested transfer capability: 0x00 - SPEECH
– Called g0/1757606XXXX
– DAHDI/1-1 is proceeding passing it to DAHDI/8-1
– DAHDI/1-1 is ringing
– DAHDI/1-1 answered DAHDI/8-1

If you dial the exact numbers Asterisk is dialing from an analog phone connected to the line what happens?

i have a remote softphone in my office for testing purposes, when i dial the number it connects right away.

the purpose of the misc destination is that it will follow the path the same as a dialled number.
so you can dial from your softfone but not from the ivr forward to misc?

try making a misc application to dial the misc destination.
Description : Test dialout
Feature code : 3
Feature status : Enabled
Misc Destination Divert After Hours

then dial 3 from your softfone.
it should dial whatever you put in your misc dest.

Hope this helps.

the Misc Application workaround worked… i set the feacture code to 9 using the Misc Destination and when dial 9 from my phone the call connects right ok.


but now how can i add the Misc Application to my IVR, i dont see it under my list of option.