How to list the newest available versions of the modules at mirror.freepbx.org, mirror1.freepbx.org, mirror2.freepbx.org?


(Reinhard Stindl) #1

I have a freePBX 15 machine (15.0.16.75), which does not see all current versions of modules on the freePBX mirror server. I cleaned the folder admin/modules/_cache, changed the admin module caching in the advanced setting, no luck!
Is there a way to connect to mirror.freepbx.org and actually list what is offered to my server? I changed the repository address from https://mirror.freepbx.org to http://mirror1.freepbx.org,mirror2.freepbx.org and was able to download the newest version of EPM using the tag-version option…now I get “is newer than online version” in module-admin.
What’s wrong?

I am located in Europe…by the way…just in case the routing is different…


#2
fwconsole ma listonline --edge

To see modules in edge, remove --edge to see stable modules.


(Reinhard Stindl) #3

Thanks, I tried “fwconsole ma listonline” previously…but this is just the same as module-admin shows me
my endpoint is newer than online version
endpoint

when I enter “fwconsole ma listonline --edge”
(my) endpoint is still newer than online (edge) version, which cannot be true!!!


(Reinhard Stindl) #4

How is it possible that my freePBX machine cannot see newer versions of the EPM module…not even in edge mode?


#5

Just means the EPM you download hasn’t been officially published to either repo yet. Not uncommon for test versions. Think of edge as beta, you have an alpha.

For the gpl modules, you can always manually check git to see what’s new, but not so with the commercial modules.


(Reinhard Stindl) #6

Thaaaanks a lot! I downloaded it, because it was a requirement for Sangoma-Connect. I thought it is already an official version!

(non existing) problem solved :smile:


(Lorne Gaetz) #7

15.0.27.43 is published to edge. On my 15 distro system:

# fwconsole  ma listonline --edge | grep endpoint
| endpoint             | 15.0.27.43 | Enabled and up to date                     | Commercial  |
# fwconsole setting MODULE_REPO
Setting of "MODULE_REPO" is (text)[https://mirror.freepbx.org]

Can you PM your deployment ID to me.


(Reinhard Stindl) #8

just did…thanks!


(Reinhard Stindl) #9

Lorne Gaetz solved the problem. Altough I just use the EPM with a Sangoma s705, I once bought a full license of EPM, which is still valid…yet, the update license has expired…
That’s the reason why it doesnt show any new versions in module admin. I always thought module-admin shows all available updates, but declines updates if the update license is expired…?!

Thanks for your help…both of you!


(TheWebMachine Networks (Sangoma Software Development Partner)) #10

As an aside, mirror2 should never be specified (remove it from your repo list if you have it there). It’s been offline/depreciated for YEARS. mirror is the newest repo mirror, mirror1 is legacy/backup and is still available.


(Reinhard Stindl) #11

I just played around because I was confused :wink:
It is set to https://mirror.freepbx.org already…thanks


(TheWebMachine Networks (Sangoma Software Development Partner)) #12

I had mentioned it because there was an issue where, even if you followed normal upgrade paths from older FreePBX versions, the legacy mirror list was being retained and the new mirror. was not being added during major version upgrade…so a lot of systems out there, even on v15, still have old mirror lists because they got carried over from older versions during upgrade/migration/etc. I tend to mention it to anyone I can because, with mirror1. bouncing on and offline like a yo-yo most weekends and mirror2. entirely gone, some folks have a mighty difficult time getting their systems updated.


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.