How to get the Follow Me interface within VM locator

I’ve made a fresh install of TB 2.6.

Nothing seems to be appear in the ARI follow me user interface.

How to get that ?

Here is a post with reference to this issue in TB forums,

I’ve tried almost everything to have my Follow Me interface appear within the VM Locator.

  1. I’ve uninstalled FreePBX from the the Package manager.
  2. Re-installed FreePBX again from the package manager.
  3. Updated FreePBX to 2.4 using the Module Admin.

However, I still don’t find the Follow Me interface within the VM Locator. Rest all works OK !

The last resort would to copy the files from some other box but is there any other viable option ? This would be really cumbersome.

Whats the fix to it ?

Please realize that Fontality has “forked” the FreePBX code for there own purposes starting with trixbox 2.6.1, so if you are using the latest trixbox version that the problem you are having is directly related to something they have done beyond the control of FreePBX.

Since they have not delivered on the promise of submitting back patches for things they deemed a problem and in need of being “fixed” it is almost impossible for us to know what is going on if you are using the latest trixbox builds.

Also pulling FreePBX via the trixbox package manager instead of directly from FreePBX means that we/you do not have control over it being our known code or maybe trixbox touched code.

Are you sure that you have the follow me module loaded and active via the module admin?

I am 100 % sure that the follow me module is loaded.

The follow me functionality works flawlessly. Its just the options that are not loading within the follow me web page. There is just an update button. I am sending you access to my server in a private message.

What do you suggest ?

OK ! What if I copy the freePBX recording/* files into my /var/www/html/recordings directory

The only thing that I’m worried is that,

  1. It may break the trixbox PBX interface
  2. I really don’t know which files to copy from the freePBX tarball to have my follow me working.

I’m sure the error is only due to missing of the right files. The link to the post that I’ve sent to you clearly states that.

the web address you sent does not allow me access. It sounds like you need to increase the memory limit on PHP if the page is showing but the items are missing.

edit the /etc/php.ini file search for memory_limit and make sure that it is at least 64M, if it is at that increase it to 100M, save it and restart httpd and test again.

There should be no issues with the memory limit as all of the other pages display.

Anyways, I’ve increased the limit from 64M to 100 M.

I’m positive that the files are missing or there is no code in the file for the follow me GUI in ARI VM*.

Can you please check again, I’ll appreicate


"does not allow access " --implies

  1. You’re not able to see the page
  2. Or you’re unable to login ?

The page should come up for sure and you should be able to login.

If you do a fresh install of TB, I get the feeling that you are testing. And if you are testing you could download PBX in a Flash from and give that a try. I am sure that FreePBX will work “right out of the box” when using this distro.

The link you provided was http//:… instead of http://… and in firefox if you cut and paste it, by default it will take you to the page (i.e. not working) yea I didn’t realize it and was not thinking clearly i guess. Sorry.

I see what you get and the only way I only get that for a extension is IF…
you have enabled follow me but NOT yet defined a follow me setup for that extension so there would be NOTHING to select…

Have you as the admin defined a follow me setup for that extension?

Well thats not the solution.

If there is a problem, you look into it and try to resolve it. Switching to some other distro just because there was some trivial issue is not very appealing to me.

Can you help me with this,

I’ve downlaoded the latest FreePBX tarball,

Assuming that I’m on a centos machine, How do I install that onto my system?

You could read the documentation on this site:
Install on Centos 4.3

Or install on Centos 5.1

Short story:
Download latest FreePBX from this site, save it in /usr/src, untar it, go to the newly created directory, run ./install_amp

But, it is not guarantied that it will work from TB menus, you should go to http://yourbox’ip/admin and log in from there.

But my strongest recommendation (my own humble opinion) is to give PBX in a Flash a try, that WILL work, or you could just continue to fiddle around with what you have and hopefully some day get it to work.

trixbox has a history over the last 10 months (since releasing tb 2.2.4) of releasing changes without fully testing things. Changing things and not telling people about it until they have been caught doing it. Think about it, that causes a big support problem since the platform you built the other day can NOT probably be duplicated next week or next month because of these forever changing releases with no documentation, it’s hard to track things working or NOT. If you NEED to rebuild a box 6 months from now it not possible as they remove the old release of something every time they introduce a new one.

As for FreePBX when they decide to take the code and make changes but NOT PROVIDE any documentation or feedback to the origional development team as to what they are changing or why it easly becomes impossible to help people when they have a issue.

Latest example of this was the bulk extensions module 0.2.0, it works just fine with the standard FreePBX release but does not work with the trixbox 2.6.1 version of FreePBX. so who’s responsible for that? Now the writer of the Module found the problem and fixed it two days ago turning out 0.2.1 yesterday, but the issue was only with this “customized” version from Fontality. That is why many of us will say pick ANY other distro and give it a try as those don’t introduce unknowns.

I used to be a huge trixbox supporter but they screwed me over 6 times in 9 weeks back in Oct - Nov 2007 loosing any trust I had for them (Funny how they went from Version 2.2.4 to 2.2.10 very quickly in that timeframe once they acknowledged the problem they created in 2.2.4).

I was able to duplicate the problem with bulk extensions 0.2.0 on a fresh install of FreePBX 2.5beta1 on a Debian server and on the latest version of trixbox. The same minor code change in bulk extensions eliminated the problem on both systems. Even though I am not a fan of trixbox, it seems like my code caused the problem in this case.

Thanks, Seth

I too have Follow me installed and from athe ARI or user portal all I have is an button on the follow me page. If I go into free PBX and set up a follow me rule I then do get some follow me settings in the follow me page of the user portal but the dropdowns for “Ring First For” and Ring FollowMe List For are blank. When I try and press the update button I get the following error:

Follow-Me list ring time not changed Number must be an interger number of seconds.

I am running Free PBX and FollowMe
I am also running trix which I beleive is before Trix started messing with the code.

I too would really like to get to the bottom of this missing Follw Me in the User Portal.

Say what …

I had my trixbox updated to FreePBX 2.5 and still the same old dilemma.

There is nothing in ARI Locator when you click the “Follow Me” link. A blank page comes up.

In 2.4, I use to see the “Update” button atleast.

After having my trixbox upgraded with FreePBX 2.5 tool, that has also vanished.

I was thinking of upgrading to FreePBX 2.5 to see if it would correct this problem and I appreciate the info that 2.5 is of no help