How to get HUDLite working with Asterisk & FreePBX?

Does anyone have even a rough guide for installing HUDLite on an Asterisk/FreePBX installation?

I’m trying to get the HUDLite server started and I’m having no luck. Fonality intends HUDLite to be used on Trixbox, but they do provide very rough documentation for installing HUDLite on Asterisk. Unfortunately, Fonality only supports HUDLite on Trixbox - they won’t help you if it’s installed on Asterisk with FreePBX, even though those are the two major components of Trixbox.

The issue that I’m currently having is that the hudlite-server service fails to start and there is little of value in the logs. I would be grateful if someone can suggest how to troubleshoot this further.


server.log shows:
2007-03-21 08:42:13: RELAY STARTED
2007-03-21 08:42:13: relayStart> IRC connect: nick(Relay) pass(password) user(irc2asterisk_relay) ircname(IRC to Asterisk command bot) address(localhost) port(6600)
2007-03-21 08:42:13: relayStart> Asterisk connect: address(localhost) port(5038)

/var/log/messages shows:
Mar 21 08:43:50 asterisk hudlite-server: hudlite-server startup failed

Check the permission on perl site NET folder they need to 0755


Thanks for the suggestion. I checked the directory you mentioned and it was already chmod 755. I then checked the files in that directory and found them to be 644. I changed them to 755 but it didn’t help, so I changed them back.

At this point, I think it would help if I obtained samples of the configuration files from a working HUDLite Server and ircd installation. Would you mind posting yours?


OK I do not run it, I just installed on someones box for them.

I am only going on what I remember doing to get it working.

I really do not anyone who uses HUD or FOP for that matter…

did u open the ports in your firewall?? or do u have a firewall??

how are you starting it (when)

I had just installed it for a fellow a few days back and I think I had to have it start after Asterisk and there is a connect.xml which must have the right passwords / ports / user

I think it was if asterisk was not started Hud would start and die, once I move it to start after asterisk I never saw that happen.
I did not really look into it has it worked and it Appeared that was the issue, we moved on.


Thanks very much for the response. I’ve troubleshot the problem a few steps further and I’m getting the following when trying to start hudlite-server manually with:

./usr/local/fonality/hud/hudlite-server password -debug9

Can’t locate Net/DNS/RR/ in @INC (@INC contains: /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 PERL2EXE_STORAGE //usr/local/fonality/hud /tmp/p2xtmp-3740) at (eval 66) line 3.

I’ve verified that Net::DNS::RR::A is installed and up to date.

On each attempt to start hudlite-server, on the Asterisk console I see:
== Connect attempt from ‘’ unable to authenticate

My context.xml contains:


And I can successfully authenticate to the Asterisk Manager using “telnet localhost 5038” and those credentials.

I’ve also posted this on the Trixbox/HUDLite forum hoping it will pique the developer’s interest enough that he will respond.

Any other ideas or suggestions?


I see this is an old post, but I am now trying the same thing.
Did you get HudLite running on your system? If so, do you remember the steps?

Here is what I did and it seemed to work ok. Add the trixbox.repo and trixboxaddons.repo to your /etc/yum.repos.d then do a yum install hudlite. Worked fine for me.


I got the server up and running but cannot make any calls in or out (inter-office). Do we need to have SIP lines for this to work?

How did you do this?

" Add the trixbox.repo and trixboxaddons.repo to your /etc/yum.repos.d then do a yum install hudlite. Worked fine for me."

I cant get the HUD lite to work on my freepbx.