How to disable MWI per extension?

I tried setting VM Options in the extension to pollmailboxes=no|pollfreq=0

This did not seem to do anything. How can I stop an extension from polling MWI? We hae a few extensions like this, either they have no voicemail or we do not want the red light indicator flashing.

If you don’t want the extensions to have voice mail why don’t you just disable it?

Two different things. I want to disable MWI, not disable the voicemail.

Low tech answer, a bit of tape over the lamp?

1 Like

A lot of phones have XML configuration files that settings like this can be changed in. What brand(s)/model(s) are we talking about here?

@dicko yes that’s the current solution, not very elegant though. I thought about opening the phones and desoldering the LED.

@Overkill Polycom VVX400 series phones.

I was hoping to do it through Asterisk, but I’m trying to mod the XML now. Not sure in which config file I would insert the code. I thought I could upload the config through the web UI as we’re not booting the phones from TFTP.

<MESSAGE_WAITING 
    se.pat.misc.messageWaiting.inst.1.type="silence" se.pat.misc.messageWaiting.inst.1.value="0" 
    se.pat.misc.messageWaiting.inst.2.type="silence" se.pat.misc.messageWaiting.inst.2.value="0"
    se.pat.misc.messageWaiting.inst.3.type="silence" se.pat.misc.messageWaiting.inst.3.value="0"
/>

The Asterisk voicemail app will sent a “SIP notify” to whatever is defined as

voicemail=

in the extensions context, normally it is the same as the extension but you could change that, but other things would likely break, or more robustly modify voicemail.c and recompile if you prefer that route.
You can override the notify process by setting “externnotify” in /etc/asterisk/voicemail.conf to a script customized to your needs.
You can send all voicemail to an email address and delete it directly in the GUI by extension (no MWI then :wink: ).
Desoldering leds on a SMT board needs quite quite some skill (and very good eyesight) you might want to short it out as that would be easier.

Such details … thanks dicko! Lots of options, will see how I can slice this one. Sometimes a dirty hack is what does the trick best.

Wasn’t able to get the phone XML update to pass the messageWaiting value (though in the log it appears as though the settings were saved), will try tinkering with that a bit more.

The XML stuff is probably just for the audio indication of MWI that is played when you go off-hook, you might want to leave that on at least for your ADD challenged user :slight_smile:

That part is the audible, light should be
up.mwivisible=“0”

1 Like

Thanks for clarifying guys. I was looking at the basefile in EPM and this is what I thought was related to MWI, guess I should have dug a bit deeper.

Do you know if

up.mwivisible="0"

is a variable that can be updated through telnet or the web UI by uploading (for example) Export_config_files.cfg with this variable included? Or only in sip.cfg from the provisioning server?

how did you know they are ADD :wink: haha

I do not know; backup + test + react? :smiley:

My inclination is that you can do something like what I did to disable the missed calls from scrolling on our phones which ALWAYS ring for customer service calls and get picked up by someone else most of the time:

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<!-- Generated features.cfg Configuration File -->
<polycomConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="polycomConfig.xsd">
  <feature>
    <feature.callListMissed feature.callListMissed.enabled="0"></feature.callListMissed>
  </feature>
</polycomConfig>

Nope. Tried closing the XML tag with </> and with <></>

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<!-- Generated site.cfg Configuration File -->
<polycomConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="polycomConfig.xsd">
  <up up.mwiVisible="0" />
</polycomConfig>

I’m using a SPIP 321 phone and it was listed in site.cfg; you may need to provision this.

After another round of tests, unless I also have to disable something else like the phone’s polling or something, I’m out of ideas. YMMV for other models; I’m using 4.1.1.0260 FW btw.

Yes, I am in the process of testing with the PBU file :blush: just thought I’d ask, in case you know it. I have had a hard time with Polycom giving out technical details to non certified techs in the past, not sure if it’s changed much now so it’s a bit of shotting in the dark.

<up up.mwivisible="0"
/>

Disabling missed calls might be another possibility …

Edited my post above with new results, xpat :cry:

In the Extensions Module, locate the “mailbox” field for the extension in question. It should read something like

[email protected]

Where 40 is the extension number.

Change 40 to an extension that does not exist, and you will get no voicemail notifications.

It may also work to just delete the entry in the mailbox field altogether, but I haven’t tried that…