How to configure app_meetme or app_confbridge?

I have installed the conference module in my freePBX and tried tie setup a conference room. But I keep getting the message “Neither app_meetme nor app_confbridge is configured in Asterisk, conferencing, paging and other functionality will not work properly”.

How should I configure to have a working conference room ?
I have the confbridge.conf present in the system too.

Settings, Advanced Settings, Conference Room App.

1 Like

This would imply you don’t have those Asterisk Modules installed. FreePBX will auto choose which ever you have if you only have one. If you have both it will set it. If you are using any modern version of Asterisk, you should choose app_confgridge as meetme is deprecated and will be removed, and requires DAHDI drivers or dummies to work.

1 Like

Try this:

;(901): Room added by system
exten => 901,1,Set(CHANNEL(language)=en-US)
exten => 901,n,Set(CDR(accountcode)=1)
exten => 901,n,Answer()
;exten => 901,n,Set(CONFBRIDGE_JOIN_SOUND=beep)
;exten => 901,n,CONFBRIDGE_MOH=default)
exten => 901,n,Set(CONFBRIDGE(user,music_on_hold_when_empty)=yes)
exten => 901,n,Set(CONFBRIDGE(user,music_on_hold_class)=default)
exten => 901,n,ConfBridge(${EXTEN})
exten => 901,n,Hangup

After I changed to app_confbridge the message disappeared and my conference room started working.
Thanks !

Did you have app_confbridge loaded and installed on your Asterisk installation already and were still getting that message? If that is the case, then it sounds like you should report a bug to us. From my recollection, not having gone back to the code to verify, if you have it set to one of the two, and we don’t detect the that the Asterisk module is present for that one, we will automatically switch it to the other assuming we detect that Asterisk module is installed. Only if neither is installed should that error message come up.

I had app_confbridge installed. Initially, I selected meet_me and when I connected to my conference room, the call was being disconnected automatically. I had meet_me.conf generated automatically in the configuration files.
But, FreePBX did not auto-choose. I later had to go and select app_config in the conference room app. Only after that, did my conference room work properly and calls got connected and this message disappeared from the system status screen.

I am using Asterisk 13.1 built inside docker. It was built from the docker image jmar71n/freepbx.

not that I use conferences or paging (actually paging I could want…) but,
on my FreePBX +A11 [quote=“lgaetz, post:2, topic:32413, full:true”]
Settings, Advanced Settings, Conference Room App.
says the app_confbridge is experimental… is that still the case or is the help text old?

Help text is out of date. Use it. Love it. Don’t look back.

1 Like