How to change default IAX port?

Hello Everybody,

I want to change default iax port(4569) used in iax2 trunk. I am using freepbx 2.8 with asterisk 1.8. Please help me out!


Have you looked at the IAX Settings module?

First, you can’t use 5060 for IAX that port is used for SIP.

Second, use the command 'iax show settings" in the CLI to check the driver bindings.

Hello SkykingOH,

I have changed this port in the “Asterisk IAX Setting” …in the other iax settings like…


and have included port=5060 in all iax trunk setting (both outgoing and incomming setting)

But the following output is shown from “iax2 show peers” command:

Name/Username Host Mask Port Status
BDDX2/usabddx2 5060 Unreachable

I used elastix, when i setting like up (but i use port=8080), i get output from “iax2 show peers” 8080 Unreachable

I disable firewall and when use command “netstat -nlp | grep 8080” output no open port 8080

command “iax show settings” no work for me:
a-srv-elastix*CLI> iax show settings
No such command ‘iax show settings’ (type ‘core show help iax show’ for other possible commands)

Sorry there is no iax show settings

You also don’t need separate inbound and outbound if they go to same server. One peer can do both.