How to change admin user name and password after 2.9.0.9 upgrade

After upgrading I can no longer login. What setting control access to the “FreePBX Administration” item on the initial page?

I read many posts on how to change the user name and password but nothing works. Is this done via a config file, stored in the database, or both?

Thanks.

if you know how to get into your Linux prompt do a

amportal admin auth_none

and then go into the Web GUI and change your credentials.

Then turn authentication back on either in the Advanced Settings or with:

amportal admin auth_database

Thanks, that did it. I still had to provide a user/password admin admin, but it works now.

amportal.conf has AMPMGRUSER=admin, but password was different.

Thanks for your help.

Andy

First, in version 2.9 the setting in amportal are now stored in the database.

The second item is AMPMGRUSER is the password to allow FreePBX to connect to the Asterisk Manager Interface.