How to block incoming calls to certain extensions?

Using FreePBX…

How do we block incoming calls to certain extensions? We have a lot of extensions on our shop floor and don’t want spouses/friends/etc calling our workers at will. We accomplished this with trixbox using extensions_custom.conf and did this…

[ivr-4-custom] exten => 400,1,Goto(ivr-4,s,begin) exten => 401,1,Goto(ivr-4,s,begin) exten => 402,1,Goto(ivr-4,s,begin)

…to send callers back to the start of the ivr if they dialed an extension that we blocked. We felt this was pretty hacky but could not find a better way since there is no “class of service” in Freepbx. Is this still the only way to do this?

How about you just change “Direct Dial” in the IVR setup to a directory instead of “Extensions.” That directory could contain all extensions that are allowed to be dialed.

The settings for “Direct Dial” are “All, Disabled, Extensions.” I don’t see how to set it to a directory. What am I missing?

add the extension on the IVR and just set the destination to terminate call.

25 extensions!?!?!?

Do you have the new Directory module? Are you running a current-ish version of FreePBX? I have Directory module and 2.9; if I create a directory it shows up in that dropdown list.

Ok I see what you are saying but doing it this way makes dialing an extension very cumbersome.

I don’t think you see what I’m saying :slight_smile:

Dialing an extension is exactly the same; I’m not saying you have to use the directory to select an extension. The directory is used to limit what extensions can be dialed. If you put 25 extensions into the directory, those 25 extensions can be direct dialed, any others cannot.

Ok maybe I am confused. I have the extensions I want dialed in a directory. Now in my IVR where should I reference it?

It should appear in the “Direct Dial” dropdown. This is the “Directory” module, not the “Phonebook Directory” module, correct? The new one by Schmooze (OMG I feel like such a tool typing that out) integrates into the IVR module.

I have module admin I have “Directory freepbx”, “Phonebook Directory freepbx” and “Directory schmoozecom”. Under applications I have “Directory” and that’s it. That is what I used to create a directory. The option “directory” does not appear in the direct dial dropdown.

Hmm, I’d try uninstalling the FreePBX directory module. My understanding is that it’s deprecated and no longer supported, not sure why they still have it online. Maybe it’s causing problems? Not sure what else to suggest, it works great for me.

Ok… thanks. I appreciate all your help!

I uninstalled the freepbx directory and “directory” did not show up in the direct dial dropdown. Then I uninstalled the schmooz directory and reinstalled it. Then “directory” showed up in the dropdown. There is something buggy between the two modules but at least it works now. Thanks!!!