How I can patching bugs?

Hello!

I have AsteriskNOW 1.5 (CentOS + Asterisk 1.4 + FreePBX). Now I to want patch file and I have wget link:
wget ‘https://issues.asterisk.org/file_download.php?file_id=22615&type=bug’ -O - | patch -p0
But I don’t know where I must put this commend and how I can recompile Asterisk? If I put link I have this meesage:

[root@localhost ~]# wget ‘https://issues.asterisk.org/file_download.php?file_id=22615&type=bug’ -O - | patch -p0
–23:59:41-- https://issues.asterisk.org/file_download.php?file_id=22615&type=bug
Resolving issues.asterisk.org… 76.164.171.231
Connecting to issues.asterisk.org|76.164.171.231|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [text/plain]
Saving to: `STDOUT’

[  <=>                                   ] 10,102      34.7K/s   in 0.3s

23:59:42 (34.7 KB/s) - `-’ saved [10102]

can’t find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:

|Index: main/manager.c
|===================================================================
|— main/manager.c (revision 193868)

+++ main/manager.c (working copy)

File to patch:

And now I don’t know what I can do?
Please help me.

While we all use asterisk here, this is not really the forum for compiling and build issues with asterisk and as such you might not get a answer here.

Have you tried to post this in the asterisk forums? or better yet have you tried the AsteriskNow forums as you are trying to apply a patch to a distro, which might break things (Some distros do not like you to do a custom re-compile, others do not care).

Also if you google for help linux patching you’ll learn quite a bit. patch --help will also provide help.

This is a basic linux OS command and there are many howto’s available on how to build, make and use patches.