FreePBX | Register | Issues | Wiki | Portal | Support

How can config OPUS codec parameters in freepbx distro?


(Alaa Elkhawaga) #1

hello
as i know i should config default opus codec from /etc/asterisk/codecs.conf
but after installed latest freepbx distro i can not find codecs.conf file
how can i modify current opus parameters ?
https://wiki.asterisk.org/wiki/display/AST/Codec+Opus


(James Zhu) #2

you may check the codec from:
https://wiki.freepbx.org/display/FPG/Asterisk+SIP+Settings+User+Guide
if there is no “box” for Opus, you have to wait for update.
maybe you can use editor from gui to edit the config file.


(Alaa Elkhawaga) #3

i already using last ISO and installed complete version, and already checked box
but i do not know from where can i edit configuration for OPUS codec
for example i need to enable FEC + VBR (variable bit rate) to avoid packet loss
http://blogs.asterisk.org/2017/04/12/asterisk-opus-packet-loss-fec/


(Alaa Elkhawaga) #4

any update guys ?


(Andrew Nagy) #5

There is no codec module in freepbx. Instead do what James said and use the config editor module to edit the config for codecs.conf


(Alaa Elkhawaga) #6

there is no codecs.conf file exist in path /etc/asterisk
at same time asterisk pointed to edit its config from codecs.conf
so that i asked how to edit it?


(Andrew Nagy) #7

Add the file and then edit it.


(Expresspotato) #8

My distro didn’t have a codecs.conf either, so I created one an added the following. Any way to check if fec is actually enabled?

[opus]
type=opus
fec=yes
cbr=yes
packet_loss=10


(Expresspotato) #9

Although not related 100% to this, after doing more testing no real codec option can handle 10% packet loss (using network link conditioner) other than iBLC with any respect. G729, G722, G726, G711, Opus (since I can’t enable the required FEC / packet loss options) all stink! If you’re on a lossy connection seems your only option is iBLC?


(Expresspotato) #10

Hi all,

Anyone have any experience with this? Still doesn’t seem to be working for us…