Horrible audio quality on external Sangoma phone

I have a new Sangoma phone I placed at a remote office, different than where my PBX is stored. The Sangoma phone has horrible audio quality, to the point of being unusable. The audio from the caller is extremely choppy, to the point of dropping for several seconds at a time, and is sometimes drawn out, as though the audio has been slowed down.

I have a Digium D40 phone on a different extension but at the same remote office. It works perfectly fine with perfect audio quality and no delay. I had the Sangoma S500 phone at the main office, where the PBX is, last week and it worked great there. I have tried updated firmware (, played with jitter buffer, and codecs, nothing has worked to fix the issue. I also brought a second Sangoma phone out here from my main office and am having the same issues with that phone, however it works great at the main office where the PBX is stored.

If I pull a recording of the call, the caller can be clearly heard on the recording. Also, the person speaking into the sangoma phone can be clearly heard by the caller. The poor audio quality seems to happen when sending the callers audio from the PBX to the Sangoma phone. However, audio from the Sangoma phone to the PBX works perfectly.

I’ve tested the internet connection at the remote office and it seems fine.

I can’t find any settings in the Sangoma template I’m using in EPM that would make a difference. I’ve played with the jitter buffer in the Chan SIP settings, but that seemed to make it worse. I’d really like to outfit the whole office with the Sangoma phone, so I’m hoping to get this figured out. Any ideas would be appreciated.


Well, I somehow stumbled upon the issue. Although I’m not sure why this affected just the Sangoma phones. I had QoS turned on in my Asus RT-N66u router. Turning OFF QoS fixed the problem, which seems counter-intuitive. It’s odd this only affected the Sangoma phones.

These are settings I had on the QoS. Are these just the wrong settings? I feel like it will be beneficial to have QoS on in the long run.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.