FreePBX | Register | Issues | Wiki | Portal | Support

High task processors queue and full ram usage


(Rajeevkk) #1

hello,

High queue of task processors

subm:cel_aggregation_topic
subm:manager_topic-

task processor queue size keeps on growing to more than 90,00,000 in five mins.
RAM usage goes upto 32 GB and voice quality drops and finally system hangs
I tried latest FreePBX with asterisk 13, 14 & 15 also.
OS:
Linux freepbx.sangoma.local 3.10.0-862.2.3.el7.x86_64 #1 SMP Wed May 9 18:05:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Usage:
200 channels trunk Inbound with 13 queues & 5 extensions in each queue.
Total:
Trunk >> 1
Inbounnd routes: >> 14
Queues >> 14
Extensions >> 70


(Psdk ) #2

Hi,
Disable the CEL from advanced settings and check the result.


(Rajeevkk) #3

Version:
12.7.4-1804-2.sng7

No change even after Disabling CEL.


(Rajeevkk) #4

Hello,

Tried in 3 different Hardware with 64 gb ram also. But still same issue.
RAM usage increase in few mins to full. System hangs. Cannot even login with ssh.
some issue with Memory leak.


(Rajeevkk) #5

Hi,
After disabling cel logging in Advansed setting,
only subm:manager_topic queue is growing in task processors.
pls help.


(Dave Burgess) #6

Is there a ticket on this yet? We’re not going to be able to help you much, since we’re all users just like you.


(Rajeevkk) #7

I don’t know about the ticket generation.


(Itzik) #8

Paid support is available at support.sangoma.com


(Tom Ray) #9

Hey, how about we see some actual data from the box? What is the load? Where is the htop output to show what is running and what it is sucking up for resources?

What are we saying a ticket needs to be open for?


(system) closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.