High CPU usage in idle: recordingreport

Hi there,

After upgrading a few modules since a few days ago, I’m seeing insane high loads from a cron job that runs every 15 minutes:

/usr/sbin/fwconsole recordingreport -s -q

It finishes in 10 minutes or so and returns (obviously) in the next 5 minutes with the high CPU usage - repeating for ~10 days now.

I’ve tried to run this command with verbose argument (-vvv) and there’s no output to help diagnose the problem.

I have a few questions:

  • What this command does? I do have the commercial module Call Recording Report, is it related?
  • Is it safe to comment-out this cronjob for now?

My setup is running the FreePBX distro with FreePBX, all modules updated.


1 Like

I’m also experiencing the same issue.
I have one PBX server (FreePBX fully updated which is having this issue, and another PBX server (FreePBX slightly out of date (around 90 days out of date) and it doesn’t have this issue.

Edit: The PBX server (FreePBX that this is happening on currently isn’t in use. There are no users registered to it and all trunks disabled etc, but for some reason the recordingreport is taking up all the CPU usage.

I’ve compared the module versions of the Call Recording Report module.
The non-high utilization one is version where as the latest version with high utilization is version
I’ve rolled back the version from to and rebooted the server and the CPU utilization has gone down.
Not sure which version between and that causes it but the issue is gone with

1 Like

Mine was also upgraded from directly to

This was from my last update log:

Upgrading module 'recording_report' from to
Module recording_report successfully downloaded in 11 seconds

I usually upgrade the modules once a month.

I suggest opening a bug report.

No one did this unfortunately. So I did it for you and I fixed it https://issues.freepbx.org/browse/FREEPBX-17903

Please open a bug report next time.

If you run the command with -q and -vvv those are conflicting statements -q is quiet and -vvv is verbosity. So you are saying “Give me all the verbosity but shutup”. Removing -q would have gotten you what you wanted.

Thanks a lot for fixing the problem!

I’ve tried to open a bug report but the process was so bureaucratic that I just gave up.


It’s not that bad. I open up a new one about every week and creating it goes quickly.

1 Like

Hey Guys, I’m seeing similar results on one of my VM’s I’ve recently updated. It’s running

Just sits on 100% CPU most of the time now, it doesn’t seem to affect call quality, although this particular instance is only a couple of extensions as it’s new.
The process in question here is php run by asterisk user…

    top - 08:24:25 up 4 days, 17:32,  3 users,  load average: 3.55, 3.62, 3.85
Tasks: 127 total,   2 running, 125 sleeping,   0 stopped,   0 zombie
%Cpu(s): 96.0 us,  3.6 sy,  0.0 ni,  0.0 id,  0.0 wa,  0.0 hi,  0.3 si,  0.0 st
KiB Mem :  1015556 total,   266628 free,   482032 used,   266896 buff/cache
KiB Swap:  2097148 total,  1535996 free,   561152 used.   310740 avail Mem

18308 asterisk  20   0  413640  29256   1040 R 91.0  2.9   8:29.38 php
  492 asterisk  20   0  749068  53564  33556 S  4.3  5.3   0:08.57 httpd
 1215 mysql     20   0 1177444  77844   1860 S  1.0  7.7  34:10.39 mysqld
 1695 asterisk  20   0  941576  10132   1368 S  0.3  1.0   4:07.84 PM2 v2.10.1: Go
 1791 root      20   0  837564   6808      0 S  0.3  0.7   4:56.59 fail2ban-server
 1903 asterisk  20   0 1633644  47552    260 S  0.3  4.7  19:47.99 asterisk
18421 asterisk  20   0  390768   7840   1156 S  0.3  0.8   0:00.75 php

This is running on a barebones SSD VM and had been running fine up until the upgrade.
I’ve tried turning Edge on to see if it made any difference, but it doesn’t seem to have, I will check the modules are upgrading after re-enabling Edge again.


Your screenshot below doesn’t prove this is related to recording report at all. You need to identify what is the process php is executing.

After looking further into the process, you’re right actually, It seems to be this process…

 [[email protected] ~]# ps -aux |grep 32264

root 24209 0.0 0.0 112704 972 pts/0 S+ 21:10 0:00 grep --color=auto 32264

 asterisk 32264 90.8  0.2 413640  3032 ?        Rs   09:05 658:08 php /var/www/html/admin/modules/restapps/restapps.php

Is this module important and required?


How many CPUs (or Cores) does this thing have on it?

One I believe, it’s a VM on SSD hardware

I am experiencing the same issue with 100% CPU utilization on a new install. No phones connected yet.

top shows that php is running at 100%

ps aus|grep php shows culprit is restapps.php

asterisk 20798 93.4 3.8 413864 39032 ? Rs 00:24 9:25 php /var/www/html/admin/modules/restapps/restapps.php

Did you find any resolution for this?

Again. This thread is about “recordingreport” and your paste clearly shows RESTAPPS.

Closing this thread. You should consider opening a new thread about RESTAPPS.