High Availability Cluster not starting after motherboard change on seondary node

I had to change the motherboard on my secondary HA node. The NICs had different names and I had to change the ifcfg files in network-scripts.
Then I tried to bring the cluster back online, but now it’s completely broken and FreePBX and Asterisk no longer starting, no matter what node I try to use. I now have the node with the changed NICs shutdown, but the cluster is no longer starting on the one where I didn’t make any changes.
@xrobau , please help!

Node freepbx-b: UNCLEAN (offline)
Online: [ freepbx-a ]

Full list of resources:

 spare_ip       (ocf::heartbeat:IPaddr2):       Stopped
 floating_ip    (ocf::heartbeat:IPaddr2):       Stopped
 Master/Slave Set: ms-asterisk [drbd_asterisk]
     Slaves: [ freepbx-a ]
     Stopped: [ freepbx-b ]
 Master/Slave Set: ms-mysql [drbd_mysql]
     Slaves: [ freepbx-a ]
     Stopped: [ freepbx-b ]
 Master/Slave Set: ms-httpd [drbd_httpd]
     Slaves: [ freepbx-a ]
     Stopped: [ freepbx-b ]
 Master/Slave Set: ms-spare [drbd_spare]
     Slaves: [ freepbx-a ]
     Stopped: [ freepbx-b ]
 spare_fs       (ocf::heartbeat:Filesystem):    Stopped
 Resource Group: mysql
     mysql_fs   (ocf::heartbeat:Filesystem):    Stopped
     mysql_ip   (ocf::heartbeat:IPaddr2):       Stopped
     mysql_service      (ocf::heartbeat:mysql): Stopped
 Resource Group: asterisk
     asterisk_fs        (ocf::heartbeat:Filesystem):    Stopped
     asterisk_ip        (ocf::heartbeat:IPaddr2):       Stopped
     asterisk_service   (ocf::heartbeat:freepbx):       Stopped
 Resource Group: httpd
     httpd_fs   (ocf::heartbeat:Filesystem):    Stopped
     httpd_ip   (ocf::heartbeat:IPaddr2):       Stopped
     httpd_service      (ocf::heartbeat:apache):        Stopped
 Clone Set: ClusterMon-SMTP-clone [ClusterMon-SMTP]
     Stopped: [ freepbx-a freepbx-b ]
 fence_b        (stonith:fence_ipmilan):        Stopped
 fence_a        (stonith:fence_ipmilan):        Stopped

 Those are the ifcfg files for my node with no changes.
![image|690x174](upload://y5hVYkpkY0CQ1MMgj5piOsB6tSm.png)
[[email protected] network-scripts]# ifconfig
em1       Link encap:Ethernet  HWaddr 44:A8:42:3C:1D:C9
          inet addr:10.1.1.176  Bcast:10.1.31.255  Mask:255.255.224.0
          inet6 addr: fe80::46a8:42ff:fe3c:1dc9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:130716 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1032 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9505239 (9.0 MiB)  TX bytes:130068 (127.0 KiB)
          Interrupt:18

em2       Link encap:Ethernet  HWaddr 44:A8:42:3C:1D:CA
          inet addr:172.27.91.1  Bcast:172.27.91.255  Mask:255.255.255.0
          inet6 addr: fe80::46a8:42ff:fe3c:1dca/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:76651 (74.8 KiB)
          Interrupt:19

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6874 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6874 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:917619 (896.1 KiB)  TX bytes:917619 (896.1 KiB)

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:172.16.5.116  P-t-P:172.16.0.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

I think one of my problems is this:

I have one only one sever turned on, freepbx-a, but it shows it’s slave for all the services.
How do I manually make one server (or individual services) make master with the other node being turned off?

Master/Slave Set: ms-asterisk [drbd_asterisk]
Slaves: [ freepbx-a ]
Stopped: [ freepbx-b ]

Was able to fix it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.