Help with Voicemail Transcription

I was wondering if there is a way to debug @tony722 's transcription script. I have followed the steps, and I can even see the stream.org file created in the /tmp folder, however when the email is sent, the transcription is not in the email.

I have tried to run the glcoud command manually

 gcloud alpha ml speech recognize-long-running tmp.A3u6Pkq6gE/stream.org --language-code='ro-RO' --additional-language-codes='it-IT','en-US' --enable-automatic-punctuation --interaction-type='voicemail'

but kept getting

“PERMISSION_DENIED: The caller does not have permission”

what happens if you su to asterisk user and run the command ?

I have seen similar from my scriot that uses AWS for its transcription and its an issue with the user asterisk is running as.

Ian

Funny! I even tried your AWS script! (I THINK with your script, I didnt even get the email)

As for trying as the Asterisk, user, I think it was the same permission error. I will try in a few and report back

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.