Help with Sangoma Connect - doesn't show up in system activation

I’m trying to get the Sangoma Talk app on Android and ios to work with my PBX. It’s my understanding that I need to buy and install the Sangoma Connect module. I couldn’t find a Sangoma Connect module in the commercial add-on store, but I did find FreePBX softphones, I assumed this is the same thing (it would be more user-friendly is names of modules were the same) so I bought it for $299. I went back to my PBX and clicked “Update Activation” under System Admin>Activation. The new module didn’t show up. I’ve now tried clicking it 5 times over the course of 30 minutes and it’s still not showing up. I’ve confirmed that I purchased the module for the correct deployment. I’m running FreePBX v.

  1. How can I get the module activated?
  2. Is the FreePBX Softphones module what I need to get the Sangoma Talk app to work?

Commercial modules usually take about 24 hours to show up on your system after purchase. It’s a known issue unfortunately.

When you purchased the SoftPhone license did you actually assign it to your Deployment? Not sure if the UI is just weird but in your license screenshot on the bottom it doesn’t seem like you have it assigned to a deployment.

I don’t think this is a correct general statement. As a counter point, I have not experienced this. I know we have seen some threads on this forum where people have experienced problems with activation, but it’s not generally expected to take a long time.

Yep, I added it to my deployment

It’s been about 12 hours and it still isn’t showing up.

Cool. You do get free support for paid modules so alternatively you can reach out to customer support and have them check to make sure that the license is properly configured on their end and that it is truly one of those times where you have to wait 24 hours.

I will say that I’ve never encountered this issue on any of my systems while I’ve seen many report it here. Not sure if I just got lucky or what.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.