Help with incomming please

I’m starting over from scratch, moving from Trixbox to FreePBX. Puting everything in by hand.

I set up our Trixbox PBX in 2008 (10 person office), its been running just fine but I will admit I forgot much of what and why I did what I did.

Only thing I have at this point is 2 phones connected to the system with one SIP Truck, using our backup Call Centric Truck.

Here is my current problem, I can call out on the SIP Trunk but when I call in I get the “ss-noservice.ulaw” not in service message.

I can call extension to extension just fine.

Can call out with no issues.

Have the inbound route destination set to an extension.

Created a conference and set the destination to that, still no joy.

It has to be a simple button or click that I’m missing, I been playing on/off now with this one issue for a week now. Time to say uncle,

Thanks everyone.

Jay

Here are the trunk details

type=peer&peer
session-timers=refuse
context=from-pstn
fromdomain=callcentric.com
fromuser=1777225XXXX
host=callcentric.com
insecure=port,invite
secret=XXXXXXXXXXXX
defaultuser=1777225XXXX
disallowed_methods=UPDATE
directmedia=no
videosupport=no
disallow=all
allow=ulaw

Here is what I get when I try to call in, I changed all phone numbers and IP address to protect the innocent. . I see no extension listed!

Connected to Asterisk 1.8.7.1 currently running on FreePBX-01 (pid = 2930)
Verbosity is at least 3
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [[email protected]:1] NoOp(“SIP/X”, "Received incoming SIP connection from unknown peer to X ") in new stack
– Executing [X @from-sip-external:2] Set(“X”, "DID=X ") in new stack
– Executing [X @from-sip-external:3] Goto(“SIPX”, “s,1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/X”, “0?checklang:noanonymous”) in new stack
– Goto (from-sip-external,s,5)
– Executing [[email protected]:5] Set(“SIP/X”, “TIMEOUT(absolute)=15”) in new stack
Channel will hangup at 2012-02-15 12:59:52.053 CST.
– Executing [[email protected]:6] Answer(“SIP/X”, “”) in new stack
– Executing [[email protected]:7] Wait(“SIP/X”, “2”) in new stack
– Executing [[email protected]:8] Playback(“SIP/X”, “ss-noservice”) in new stack
– <SIP/X> Playing ‘ss-noservice.ulaw’ (language ‘en’)
– Executing [[email protected]:9] PlayTones(“SIP/X”, “congestion”) in new stack
– Executing [[email protected]:10] Congestion(“SIP/X”, “5”) in new stack
== Spawn extension (from-sip-external, s, 10) exited non-zero on ‘SIP/X’
– Executing [[email protected]:1] Hangup(“SIP/X”, “”) in new stack
== Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/X’

“Received incoming SIP connection from unknown peer to X”

Your trunk is not setup right. Either that or your provider sends you calls from all over the place (most do).

You probably had allow anonymous calls turned on in the trixbox and you have not done that in the new install.

Check general settings.

Skyking I thank you, thats was it.

Thanks for all the help on the Trixbox forum as well over the years.

I have no issue with Trixbox, well a couple of issues but I think the writing is on the wall with Trixbox I’m afraid.

Jay

Hi , i have the same issue , i have 2 sip accounts , 1account i have configured as outbound trunk and i am able to make calls from any extension to outside. now i want to configure 2nd sip account / did no to get incomming calls to my extensions.

here i stucked and not able to configure , can any one suggest me how can i configure incomming did to receive calls in my pbx.

please let me know i am a GUI user

thanks in advance