Help with Inbound not completing

FPBX Ver 2.9.0.9

I set up a trunk group with a SIP provider with some DID’s. Outbound work fine but incoming keeps failing to “call cannot be completed as dial message”. Carrier says they are delivering the call and it is failing at the PBX. No matter where I set the DID destination it does not work (extension, ivr, feature code, etc). I have attached messages from the CLI hoping someone could point me in the right direction. Sorry if I violate any forum rules by pasting here so please advise if I should not have.

-- Executing [[email protected]:1] NoOp("SIP/10.250.0.6-00000087", "Received incoming SIP connection from unknown peer to 7542242733") in new stack
-- Executing [[email protected]:2] Set("SIP/10.250.0.6-00000087", "DID=7542242733") in new stack
-- Executing [[email protected]:3] Goto("SIP/10.250.0.6-00000087", "s,1") in new stack
-- Goto (from-sip-external,s,1)
-- Executing [[email protected]:1] GotoIf("SIP/10.250.0.6-00000087", "0?checklang:noanonymous") in new stack
-- Goto (from-sip-external,s,5)
-- Executing [[email protected]:5] Set("SIP/10.250.0.6-00000087", "TIMEOUT(absolute)=15") in new stack

Channel will hangup at 2012-03-14 14:49:53.933 EDT.
– Executing [[email protected]:6] Answer(“SIP/10.250.0.6-00000087”, “”) in new stack
– Executing [[email protected]:7] Wait(“SIP/10.250.0.6-00000087”, “2”) in new stack
– Executing [[email protected]:8] Playback(“SIP/10.250.0.6-00000087”, “ss-noservice”) in new stack
– <SIP/10.250.0.6-00000087> Playing ‘ss-noservice.ulaw’ (language ‘en’)
– Executing [[email protected]:9] PlayTones(“SIP/10.250.0.6-00000087”, “congestion”) in new stack
– Executing [[email protected]:10] Congestion(“SIP/10.250.0.6-00000087”, “5”) in new stack
== Spawn extension (from-sip-external, s, 10) exited non-zero on ‘SIP/10.250.0.6-00000087’
– Executing [[email protected]:1] Hangup(“SIP/10.250.0.6-00000087”, “”) in new stack
== Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/10.250.0.6-00000087’
[2012-03-14 14:49:54] NOTICE[3164]: chan_sip.c:22436 handle_request_invite: Unable to create/find SIP channel for this INVITE

Any one please, I’m searching for clues.

Try to enable anonymous inbound sip calls in general settings also can you post your sip trunk setup.

It worked with anonymous but isn’t there some risk involved with that? why should I have to turn that on? just curious.
BTW - Thank you for your help.

Turning on the anonymous is a good way to test if your trunk is working. Since the trunk is working the problem is probably in your config on the FreePBX system.

I can call the DID and ring the destination, when the destination answers, the caller receives “we’re sorry call cannot be completed at this time”.

This indicates your trunk is incorrectly setup. You were going to the catch all context is for anonymous sip calls. Try making your trunk name the username you are using for the trunk in your setup. Then you should see you are going to the from-trunk context. Once you have that you can turn off anonymous sip and it should work.

[Paetec]
host=x.x.x.x
username=aabbccddeeff
secret=1111111
type=peer
qualify=yes
insecure=port,invite
context=from-pstn

I modified values in posting for security purpose.