Help with Inbound calls

Hi Guys

Im new to asterisk and Freepbx. I manage to setup my freepbx and managed to create and outbound trunk and i can make outbound calls. I now have a local DID with the same sp but have no idea how to get an inbound call. Please help
Im using sip trunks

denzelm - Basic questions are best addressed by reading one of the many getting started guides.

As for your problem, suggest you look at inbound routes.

Hi

I had a look at the docs…I still can this inbound route to work, The calls is not even ringing on my Pbx

Since you provided no information it is impossible to help.

What version of FreePBX/Asterisk and how was it installed?
What type of trunk?
Is the trunk working for outbound?
Did you create a route and with what information?
Provide Asterisk log data from time of failed call.

Hi Sorry for the poor information:

I have Asterisk 1.6 with FreePbx GUI
I have a Sip trunk :
Trunk Config:
Dialing Rule : XXXXXXXXXX
Reg: username:[email protected] address

Outbound calls work fine.

Inbound:

I have a local did forwarded to the same sip account:
Trunk config:

I have added :
Password
type=peer
context=from=trunk
When i dial the local did from my mobile the call doesn’t ring it just ends immediately.

When i look at the logging on the centos box i get these two lines :

Using SIP RTP TOS bits 184
Using SIP RTP CoS mark 5

Nothing happens after that.

The sip account is working as i tested it on an xlite phone.

Regards

OK, that is better. Turn on the “allow anonymous SIP” option and test again.

If that works we know it is your trunk config and not a network issue.

Hi

Thanks for your replies once again. I did turn “allow anonymous SIP” under General tab.

I still get tha same to lines in the logging screen of the asterisk box.

Could it be my trunk config is incorrect.if so what could be wrong

Regards
Denzel

On the SIP debugging:

On the debug mode i can see the call coming in from the number dialed and i see no denys at all im not sure if i can caputure that information

Trunk config is irrelevant with anonymous SIP, all calls are processed without a peer config with this option.

The calls are never hitting your server so you must not be registering properly from the Asterisk box or you are not forwarding ports in the router correctly (which you should not have to do).

Hi There is traffic hitting my asterisk for sure as i can see the number im dialling from

Where are you seeing the calls hit? The log was not showing anything.

On the dos screen on the sever itself. sip debug on

That is the log we are speaking of it is in /var/log/asterisk/full

If large amount use http://www.pastebin.ca and post a link.

It’s not DOS, it’s a Linux shell

Just jumping in on the conversation here -

It sounds like your SIP Trunk is configured properly.

If you are able to place calls, you must have an extension registered, so that is good.

Do you have an Inbound Route configured? And, have you maybe tried using the “ANY DID / ANY CID” options? Essentially, configuring the Inbound Route, but not specifying any exact numbers, so it works more like a wild inbound route.

Then, does your inbound route pass anywhere - in the “Set Destination” section? For example, you can set it to go straight to an extension (best in your case for starting). You can also have it go to an IVR (if you create one), or straight to a Ring Group (if you define it first).

I’m kind of new at this too, and just went through a lot of this config myself.

I suggest that you contact your SIP Trunking provider and ask them for technical support.

Hi

Thanks for jumping in. I need all the help there is.

Ok so i have tested the sip account on an xlite phone and the inbound calls work so we know the sip account is fine.

I have used any DID and any CID

i have an inbound route all any to extension 1100 which is log into my softphone.

When i look at my asterisk box and watch the traces i see this

the mobile number I am dialing from

There seem to be no deny or errors however.

I have also enabled allow anonymous sip.

The fact that i can see some sort of traffic to this asterisk box from the outside means that it can be a Nat problem on my router. Having said that i also see a “Transmitting to no Nat… on the logging”

Im lost now!!

I suggest you turn on sip debugging, verbose level 10 and debug level 10 and post the log from /var/log/asterisk/full at pastebin.ca as I suggested below.

Guessing games are not fun.

[Dec 10 14:26:03] VERBOSE[11109] chan_sip.c: Reliably Transmitting (no NAT) to 192.168.16.158:62316:
OPTIONS sip:[email protected]:62316;rinstance=40ebf61df7c86f5d;transport=TCP SIP/2.0
Via: SIP/2.0/TCP 192.168.16.62:5060;branch=z9hG4bK44372a09;rport
Max-Forwards: 70
From: “Unknown” sip:[email protected];tag=as564eee80
To: sip:[email protected]:62316;rinstance=40ebf61df7c86f5d;transport=TCP
Contact: sip:[email protected];transport=TCP
Call-ID: [email protected]
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX
Date: Thu, 10 Dec 2009 19:26:03 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0

Do you know how to DMZ your Asterisk box? I would not recommend leaving it that way, but that is a quick test to see if it is a port issue.

The ports I have specifically opened to mine are 5060-5080 + 10000-20000.

When I first set mine up, I was also having audio issues between calls. When you place a call, do you have 2-way audio working?

A similar trace like yours? I don’t even know what that means.

This is a log of an extension with TCP.

If you are unwilling to upload your log to pastebin.ca I can’t help you.