HELP with FreePBX and routing

Hi all

I have recently installed FreePBX on a dedicated PC, and have the Unifi controller set up to function with SIP

Previously the speakers were operational and registered with FreePBX but after a failed update I was fored to re-install FreePBX

At that point i ran into some difficulties and was experiencing failure to register (the edu units)

I am looking for someone to join a join dot me session, assist me with getting everything back to normal operational status today, I will gladly compensate you for your time via paypal or whatever.

I have all credentials and full access to everything required to achieve this.

The router is a sonic wall, which is confiured to allow the aforementioned PBX traffic and like I said above, was previously working 100 percent perfectly.

Help!

are you having trouble with the sonicwall or freepbx?

I’m having trouble with the free PBX I believe I’m looking to compensate someone for assistance with the remote access session and I’m not looking to go back-and-forth in the hundred emails if you can help me today please give me a way to speak to you

I’m definitely not the guy for that, but they do offer support from Sangoma, https://www.freepbx.org/support-2/ they would be the best bet, but I do understand, I was going to try and help if it was a sonicwall issue, I’m pretty good with those.

Not sure how involved it is to determine if the Sonicwall is blocking my inbound Sip traffic

Are you familiar with doing a packet capture on the Sonicwall?
It’s relatively simple. You can read your Sonicwall manual if you don’t know how.

I would be happy to help, but could you please describe your problem with a little more depth?

basically everything worked fine, freepbx was set up, sonicwall was configured, everything was great.

During an update to freepbx it seems to have frozen (the update), so I rebooted it.
It was hosed, so I re-installed fresh.
I have the sip trunk successfully registered with the hosting provider.
When I try and dial the extension mapped to the freepbx via sip trunk, call is no longer being answered by the free pbx.
I believe I have everything set up the same, but I have a feeling it has something to do with the tons of networks freepbx kept asking me what to do with. The box running freepbx has one nic card so not sure why it even had multiple networks showing.
This is a single site network with sonicwall, and like I said the sonicwall is configured the same as it was when freepbx was working fine.

Basically looking for someone with the knowledge of freepbx to do a screen share with me on my laptop, during which I will loginto the freepbx and while I make a few calls to a DiD i have routed to the freepbx, someone can look at log files and see whats going wrong with call routing, and either fix or tell me where the issue is blocked from.

Make more sense?

as an update,
I have VPN’d into the network, and via xlite installed on my laptop can now confirm that the auto answer for paging is working fine (appears to be), when xlite is configured as an extension on the FreePBX.

So, this now being said the only thing I need help with is how to determine if inbound traffic is hitting the FreePBX when I try and dial the DiD thats routed to the freepbx from outside the network,

Anyone help?

You can start with a two-step process:

From the console on the server, logged in as ‘root’, run “tcpdump port 5060”. Make a call that hits your DID. If the traffic from the SonicWALL is getting to the server, you’ll see a bunch of stuff show up on the screen.

If there isn’t, the problem is that the SonicWALL is sending the traffic to the wrong place. If it is, check the integrated firewall and make sure that the ports are all open to the ITSPs servers.

thanks for posting this!
Is there any possible way to do this through the Graphic Interface? I am not on site and would have to be on site for the command line access from the physical server.

I also have noticed that even after clearing this, it re-appears and I have already (i think correctly), added the machine’s network to trusted.

“No Trusted Network or Host defined”

Is there a way I can factory default the networks settings but keep everything else intact?
The machine has a statically reserved IP, so it will get the same IP based on it’s mac.

Blockquote

I ran trace on sonicwall while I dialed the DiD thats routed to the SIP trunk on the freepbx.
The SIP trunk interestingly does register without issue as per dashboard in FreePBX.

Evidently when I call the DID, the sonicwall shows packet status as “consumed”, and ports are showing as:
52421,4500

I was under the impression that the 10000 to 19999 UDP rule I set up in sonicwall should be technically allowing this through without any issues.
Any suggestions on what my course of action should be?
Should I delete the settings on the sonicwall that are supposed to be allowing 10000 through 19999 and re-create them? Appreciate any insight.

By the way i was VPN’d into the network during this, so it is possible that 4500 was VPN related?
HELP!!!

Nope.

I did this, on site now, tons of traffic showing up once I started the dump.

My hosted provider said the pbx is not replying to the request.
Im stumped and extremely frustrated.
Internally via a softphone app, I can page everything perfectly.

OK, let’s try this again.

If the SonicWALL is the problem, the traffic will not get delivered to the phone server. Whatever you’ve done still doesn’t tell us if the traffic is actually getting delivered to the server.

So, one again - log into the PHONE SERVER and run a tcpdump to see what traffic is actually making it to the server. This will tell you (since apparently you’re not willing to let us interpret the output) what traffic is getting senr to the server. There should be traffic on UDP port 5060 (and possibly 5160) and some other traffic on UCP ports between 10000-20000.

One thing you said might be a clue - you keep saying you’ve “opened” the ports on the SonicWALL, but have you actually redirected them to the server?

I understand your desire to solve this without letting us help you, and I respect that, but not helping us help you (by posting the TCPDUMP output, for example) is not going to help us see what is actually happening. We are only so clairvoyant.

1 Like

hi, thanks for clarifying a bit.
I didn’t post the screenshot of the dump because nobody had asked for it and I’m used to reading when problems are posted a tad of troubleshooting first and then someone says to post the results.
My apologies.
I’m not in front of the machine now, so I cannot do this now but will check tomorrow.

Regarding your earlier suggestion of “check the integrated firewall and make sure that the ports are all open to the ITSPs servers.”, can you please elaborate and explain where I am looking for this and what the settings should be? I’m sorry but I am very new to FreePBX and don’t know my way around that well yet.

Hi. I have been busy on other project but just finished and still need to get this resolved.
Here is a pic of the data that populated once I dialed the DID that is supposed to route to the FreePBX.

Can anyone assist with this and let me know if it shows whats going wrong that the Call to the DID is not routing to a page group on the freepbx.

I believe the inbound call route is setup fine.

I think that because you’ve used the word ‘routing’, people are assuming this is a network issue. Are you saying that when calls come in to your machine, they aren’t being sent to the correct destination?

This is because your ‘Inbound Routes’ aren’t correct. If you run ‘asterisk -rvvv’ and watch when a call comes in, you will see what the DID that is being sent by your provider is.

I did the tcpdump port 5060 again and here is the result.

Can anybody confirm if the inbound call attempt is hitting the FreePBX?

Next step is to pay sangoma support and ask them to determine whats happening.
I cannot get this to work and am stumped. Any help is appreciated.