Help with Fax FreePBX Distro with Latest Updates

I am trying to get incoming fax working without success. I have downloaded a free Fax for Asterisk licence from Digium and installed it per their instructions. When I do a “fax show stats” I see no mention of licences there which I believe I should.

I have set up the Inbound route in FPBX for Fax Detection with 4 second delay and Fax Recipient pointing to the extension which I have enabled for fax and entered the email address to forward faxes to on that extension.

I have tried both SIP and Dahdi detection but neither seem to detect the fax tones.

I have spent considerable time Googling around and can’t find much that is helpful.

Any help anyone can give me would be very much appreciated, I fear I am missing something.

The Distro includes DpanDSP for faxing and faxing works out of the box with it. No need to buy Fax For Asterisk


Is there anything special I have to do to get it working, at the moment I have not been able to get inbound routes to detect fax calls.

Not sure it works for me. SIP fax detect with spandsp just works for me. My guess is the fax tone is not being sent on faxes or the SIP Carrier is not handling things right.

which fax detect method are you using on sip trunks?

The built in SIP one that comes with res_fax and chan_sip


I can now receive faxes but only with a workaround. I set the Inbound Route to Fax Detect: No, enable fax on an extension and put in an email address to receive the fax. I then set the Inbound Routes destination to Fax Recipient and that’s it.

This is not ideal but it does work. I think I have to be missing something somewhere because try as I might with and without Fax for Asterisk I cannot get the inbound route to recognize a fax.

I have tried this with the stable distro and fpbx 2.9 and the beta distro with fpbx 2.10 with similar results. The only differences I can see are in the content of the email message that is sent with 2.10 from that sent with 2.9 and the dial plan progress is slightly different.

Googling around I did find some talk from someone experiencing the same problem as I am that there might be a bug in asterisk 1.8, is there any substance in that?

See I now have Fax for Asterisk working as I would expect.