Help with connecting PSTN to FreePBX and with testing that connection

Hello everyone. I followed this guide Configure Grandstream HT813 with FreePBX, and created a trunk. I also created an outbound route, where my grandstreem trunk is put in the “Trunk Sequence for Matched Routes”. My question is, what do I do next? How do I test if my setup works, and how can I now make external calls?

I don’t believe that the guide you mentioned is workable for outbound. It shows the trunk set up for ‘Registration Outbound’, but HT813 is not a SIP registrar, so registration will always fail. There are numerous threads in this forum mentioning HT813, several of which report success.

But I don’t understand your question. Obviously, you need at least one device to make calls. Options include an analog phone connected to the FXS side of the HT813 (or other ATA), IP phone, softphone on Windows, Mac or Linux, or a SIP app on a smartphone. For each such device, set up an Extension on FreePBX and configure the device to register as that extension. You can test that connection by calling *43 (echo test), or calling from one extension to another. Once that’s working, try dialing external calls.

So if I understood correctly, I need to connect a softphone like Linephone, then I can test, right?

I followed this article:GitHub - Futur-Tech/Grandstream-HT813: Setup of Grandstream HT813 with PSTN line in France and FreeBPX

OK my bad! I confused all of this. I now setup using the guide from GitHub, and now I am going to install linephone and test if all works.

Unfortunately, when I dial an external number, a robot voice tells me, “The number you have dialled is not in service”

At the Asterisk command prompt (not a shell prompt), type
pjsip set logger on
make a failing test call, paste the Asterisk log for the call at and post the link here.
Also post a screenshot of the FXO port page of the HT813.

Before I do this, I want to be sure I am not a complete idiot. I logged in with the username being the trunk caller id and the password being the trunk secret, but isn’t that not even a user? I also cannot create a user because on FreePBX, if I go to the User Manager, add user is greyed out. What account do I use for a SIP client?

Sorry for being such a noob

Create a pjsip extension. For this purpose, you can leave all default settings. Set up Linphone with the extension number as Username, the Secret as Password and the IP address of FreePBX as SIP Domain.

With luck, it will show as Registered. Make a test call to *43 (echo test) and with some more luck it will work. If either of these fail, report results, including anything relevant in the Asterisk log.

If the above is successful, try your external call.

Thank you so much for your patience. I will test this tomorrow.

The echo test has worked. Another question before I test external calls, normally, I would just put the full phone number with the international prefix, and then it would call using the trunk I set up? Or do I have to put a special number to call externally.

Also, is it a problem if my PJSIP trunk username contains a +?

These all sound like basic configuration questions for which there are plenty of resources out there. One such resource would be a video series created by Chris that walks you through pretty much a complete setup of a PBX that you could follow to get yours up and running.

If your Outbound Route does not modify the number (prefix and prepend are blank), you should dial exactly as you would from an analog phone connected to the landline.

I don’t know, but would suggest using only letters and digits.

Well thank you all! Everything works.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.