Help with Cisco Call Manager/Asterisk Integration

I’m having problems integrating the two systems. When I use a phone on the Call Manager side to dial a number on the Asterisk PBX I can see in the logs where the calls are arriving at the Asterisk PBX but I’m getting a “NUMBER NOT IN SERVICE” recording. Calls originaiating from Asterisk PBX to Call Manager are doing the same thing. Here are the logs:

Incoming
– Executing [[email protected]:1] NoOp(“SIP/172.30.6.132-0933d9b8”, “Received incoming SIP connection from unknown peer to 6000”) in new stack
– Executing [[email protected]:2] Set(“SIP/172.30.6.132-0933d9b8”, “DID=6000”) in new stack
– Executing [[email protected]:3] Goto(“SIP/172.30.6.132-0933d9b8”, “s|1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/172.30.6.132-0933d9b8”, “0?checklang:noanonymous”) in new stack
– Goto (from-sip-external,s,5)
– Executing [[email protected]:5] Set(“SIP/172.30.6.132-0933d9b8”, “TIMEOUT(absolute)=15”) in new stack
– Channel will hangup at 2009-09-28 14:56:13 UTC.
– Executing [[email protected]:6] Answer(“SIP/172.30.6.132-0933d9b8”, “”) in new stack
– Executing [[email protected]:7] Wait(“SIP/172.30.6.132-0933d9b8”, “2”) in new stack
– Executing [[email protected]:8] Playback(“SIP/172.30.6.132-0933d9b8”, “ss-noservice”) in new stack
– <SIP/172.30.6.132-0933d9b8> Playing ‘ss-noservice’ (language ‘en’)
– Executing [[email protected]:9] PlayTones(“SIP/172.30.6.132-0933d9b8”, “congestion”) in new stack
– Executing [[email protected]:10] Congestion(“SIP/172.30.6.132-0933d9b8”, “5”) in new stack
== Spawn extension (from-sip-external, s, 10) exited non-zero on ‘SIP/172.30.6.132-0933d9b8’
– Executing [[email protected]:1] Hangup(“SIP/172.30.6.132-0933d9b8”, “”) in new stack
== Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/172.30.6.132-0933d9b8’

Outgoing
Connected to Asterisk 1.4.24 currently running on cb2365 (pid = 3833)
Verbosity is at least 3
– Executing [[email protected]:1] ResetCDR(“SIP/6000-0933d9b8”, “”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/6000-0933d9b8”, “”) in new stack
– Executing [[email protected]:3] Wait(“SIP/6000-0933d9b8”, “1”) in new stack
– Executing [[email protected]:4] Playback(“SIP/6000-0933d9b8”, “silence/1&cannot-complete-as-dialed&check-number-dial-again|noanswer”) in new stack
– <SIP/6000-0933d9b8> Playing ‘silence/1’ (language ‘en’)
– <SIP/6000-0933d9b8> Playing ‘cannot-complete-as-dialed’ (language ‘en’)
– <SIP/6000-0933d9b8> Playing ‘check-number-dial-again’ (language ‘en’)
– Executing [[email protected]:5] Wait(“SIP/6000-0933d9b8”, “1”) in new stack
– Executing [[email protected]:6] Congestion(“SIP/6000-0933d9b8”, “20”) in new stack
== Spawn extension (from-internal, 8620, 6) exited non-zero on ‘SIP/6000-0933d9b8’
– Executing [[email protected]:1] Macro(“SIP/6000-0933d9b8”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/6000-0933d9b8”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] GotoIf(“SIP/6000-0933d9b8”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] GotoIf(“SIP/6000-0933d9b8”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] Hangup(“SIP/6000-0933d9b8”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/6000-0933d9b8’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/6000-0933d9b8’
cb2365*CLI>

did you look at:

http://www.freepbx.org/news/2009-06-07/cisco-unified-cm-6-1-to-asterisk-and-freepbx-sip-trunks-powered-by-bandwidth-com

yes i did look at that. still cant get it to work. i must be doing something wrong.

Did you create a SIP trunk between boxes ? As a debug, turn on (in general settings) Allow Anonymous SIP and test.

Yes i have created a SIP trunk and have that option connected. Calls from call manager arrive at the asterisk pbx, but thats it, its as if the numbers that i created in asterisk do not exist.

I feel like an idiot!!! I got it working…i did not see the red box at the top of the screen to apply changes.

I’m having the same problem, although this is to a conference, not an extension. Anything special needing to be done?

– Executing [[email protected]:1] NoOp(“SIP/10.220.1.12-000000e9”, “Received incoming SIP connection from unknown peer to 4505”) in new stack
– Executing [[email protected]:2] Set(“SIP/10.220.1.12-000000e9”, “DID=4505”) in new stack
– Executing [[email protected]:3] Goto(“SIP/10.220.1.12-000000e9”, “s|1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [[email protected]:1] GotoIf(“SIP/10.220.1.12-000000e9”, “1?checklang:noanonymous”) in new stack
– Goto (from-sip-external,s,2)
– Executing [[email protected]:2] GotoIf(“SIP/10.220.1.12-000000e9”, “0?setlanguage:from-trunk|4505|1”) in new stack
– Goto (from-trunk,4505,1)
– Executing [[email protected]:1] Set(“SIP/10.220.1.12-000000e9”, “__FROM_DID=4505”) in new stack
– Executing [[email protected]:2] NoOp(“SIP/10.220.1.12-000000e9”, “Received an unknown call with DID set to 4505”) in new stack
– Executing [[email protected]:3] Goto(“SIP/10.220.1.12-000000e9”, “s|a2”) in new stack
– Goto (from-trunk,s,2)
– Executing [[email protected]:2] Answer(“SIP/10.220.1.12-000000e9”, “”) in new stack
– Executing [[email protected]:3] Wait(“SIP/10.220.1.12-000000e9”, “2”) in new stack
– Executing [[email protected]:4] Playback(“SIP/10.220.1.12-000000e9”, “ss-noservice”) in new stack
– <SIP/10.220.1.12-000000e9> Playing ‘ss-noservice’ (language ‘en’)
== Spawn extension (from-trunk, s, 4) exited non-zero on ‘SIP/10.220.1.12-000000e9’
– Executing [[email protected]:1] Hangup(“SIP/10.220.1.12-000000e9”, “”) in new stack
== Spawn extension (from-trunk, h, 1) exited non-zero on ‘SIP/10.220.1.12-000000e9’

Needed to have Caller ID Number: blank