Help with AT&T trunks

Tried to set up sip trunks with AT&T and failed. They could not help was hoping you guys can.

This is what they asked me to ask support
Configure number 734-8799577 & they use/send 10 digit
23 concurrent calls
AT&T nats for us
send traffic to and come for those addresss
trust two media ips &
sip options turned on send and reply
AT&T wants to see 405 error with sip options

One “huh?” question - what do you mean that AT&T is natting for you? I don’t understand how that is going to work. Please explain if you can. If your machine is behind your firewall, there are other steps on the local firewall you will need to set up.

For setting up a connection, the step order is “trunk - inbound route and outbound route - extensions”

So, set up your trunk.
The ‘host=’ on incoming side of your trunk will be

Set up the firewall to allow traffic from the four addresses.
The media IPs should be set up in the firewall as trusted hosts.

Send us a log excerpt from /var/log/asterisk/full showing us the failure and post as much as you can about your configuration so we can troubleshoot it.


The nating goes like this, we have a managed AT&T router that they manage, that plugs into our firewall, then out to our freepbx as the only destination, all ports were open during the test. I do not know if at&t should be nating this or no.

These are the settings I had when I was taking to them and they said they had no communication of sip options.









This is the snippet of the file while we were trying to get the trunks working.

OK there is A LOT wrong with this setup.

1.) You have a bunch of SUBSCRIBE requests for hints/devices that do not exist. What ever device(s) are making those request, go fix them or add the proper extensions they are trying to subscribe to. This is just causing a bunch of garbage in the log file and unneeded processing for handling these messages.

2.) Your Chan_SIP trunk settings are very poor. They need to be corrected.

Does ATT require you to send requests from a specific username and/or domain? If that is the case you need to add:


  1. Remember Chan_SIP is listening on port 5160 now. So you need to tell ATT to send incoming calls to your IP:5160 not just your IP.

  2. If they are sending callings from two IPs, then you need TWO Chan_SIP trunks. One for each IP so the PBX will accept calls from them.

What is the problem you are having exactly? Not able to receive calls? Make calls?

  1. The subscribe requests are for BLF hints on the phones I was using to which I couldn’t find speedial in the time i had.
  2. AT&T does not use any authentication only using their host ip and our ip.
  3. They are listening on port 5060, so would I then create a pjsip trunk then?
  4. They do have two ip addresses for host and then they also have two SD Media IPs I do not know what to do with.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.