Help setting up the Request-Line URI


(United States) #1

I’m using Asterisk and FreePBX 15.0.17.14 with pjsip. I originate outbound calls (no inbound) and my Request-Line URI on outbound calls looks like below, missing the user part with the phone number in front of the IP address

INVITE sip:ServiceProviderIPAddress SIP/2.0

To: <sip:1234567890 at ServiceProviderIPAddress>

The sip trunk require no registration, or authentication, Service Provider enable access by ip address.
Calls complete fine but the Service Provider requires the Request-Line to be like To header and include the number. Where should I look to correct the Request-Line?
Thank you


(Joshua C. Colp) #2

What is the configuration? Do you have an outbound proxy set?


(United States) #3

Yes. The outbound proxy set on the SIP trunk is “sip:ServiceProviderIPAddress”


(Joshua C. Colp) #4

You would need to set it to “sip:ServiceProviderIPAddress;lr” to enable loose routing and place a user in it.


(United States) #5

I just appended ";lr” to the outbound proxy and tested but it did not make a difference. I saw other configuration examples had the outbound proxy set as “sip:192.168.0.1;lr” so i tried that and it did the trick!
Thank you! Much appreciated!
AJ


(United States) #6

I just noticed after my last post that the backslash between ip address and the semi-column does not show in the message. Probably you posted that correctly and your message did not show it as well. If other people might run into this, know there should be a backslash after the ip address, before the semi-column, in order for it to work.