Help fix my DB? (Announcement module failure)

Lo there

My server recently died and was rebuilt, and I found that my FreePBX backup was anything but complete. Luckily I managed to recover 99% from the previous disk, but I have one small problem left.

When setting up (before the restore) I tried to install the announcements module.
It failed, with an error I couldn’t read (it was bigger than the popup install window and couldn’t be scrolled).

I keep being prompted to upgrade it, and get the same error, so I removed it.
If I try to re-add it, it fails again. Everything else is working perfectly.

I’ve noticed when I’m running a backup, even with the module removed, I get this message - which I presume is half the problem…clues? :slight_smile:

Here is the error

>     Initializing Backup 3
>     Backup Lock acquired!
>     Running pre-backup hooks...
>     Adding items...
>     Error: Couldn't read status information for table announcement ()
>     mysqldump: Couldn't execute 'show create table `announcement`': Table 'asterisk.announcement' doesn't exist (1146)
>     Building manifest...
>     Creating backup...

Fixed this.
It appears to be caused by the restore, after a re-install.

If you run mysql and then :

use asterisk
show tables;

I get a list of tables, including “announcements”.

If I then try :

select * from announcements;

I get told that table doesn’t exist, but I can then run:

drop table announcements;

I get the same error, but another “show tables;” no longer shows the table.

I can now reinstall it ok.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.