Help Configuring Zap Trunks

Hi,

I have a question regarding some issues I’ve been having with Zap trunks that I have set up for use with my OpenVox A400P card and an installation of Trixbox 2.6.1. The card is configured with three FXO and one FXS port.

The problem is that I am not able to call in and out consistently via the three FXO ports. The FXO ports are ports #2,3, and 4 on the card. The ports all share one inbound route and one outbound route. However, the behavior of the three ports are very different.

I have tested the system by plugging the same PSTN line into each of the three FXO ports, but ports 2 and 3 work much differently from port 4. A summary of the port issues is as follows:
Port2 FXO Can call in, but can’t call out
Port3 FXO Can call in, but can’t call out
Port4 FXO Can’t call in, but can call out

I realise that some settings must be wrong in Trixbox, but I am not sure where to look. Any help would be most appreciated.

Best,

Gaoming
http://www.rightsite.asia

What do your inbound and outbound routes look like?

Hi,

I have simplified my trunks and outbound/inbound routes a bit to concentrate on getting at least one of these lines functioning in both directions. So right now, I only have one trunk set up as Zap/4. I also have removed the other phone lines, so that there is now just one phone line attached to port 4 of my OpenVox card.

Here are links to screenshots of my
outbound routes: http://www.flickr.com/photos/mcolemail/3415622573/
and
inbound routes: http://www.flickr.com/photos/mcolemail/3415622793/
My zap trunk is set up like this: http://www.flickr.com/photos/mcolemail/3415636349/

With the system set up like this, I can currently call out through the line attached to port 4, but cannot call in.

Thanks,

Gaoming

In your ZAP Trunk, are you sure you need the “w” in the Outbound Dial Prefix?

From the tool tip:

"The outbound dialing prefix is used to prefix a dialing string to all outbound calls placed on this trunk. For example, if this trunk is behind another PBX or is a Centrex line, then you would put 9 here to access an outbound line. Another common use is to prefix calls with ‘w’ on a POTS line that need time to obtain dial tone to avoid eating digits.

Most users should leave this option blank."

Also, put the caller ID in there like “myname” <111-222-3333>

In the outbound route, you might as well put #4 as the first choice and take out the rest for testing.

Otherwise looks OK. I would make an inbound route just for that DID too.

Hi,
Thanks for the tip.

I have updated the Zap Trunk Configuration to remove the “w,” and put in the caller ID as you mentioned.

I have also updated the outbound route to remove the other zap trunk options.

However, the result is the same as before. With one POTS line attached to Port 4 of the FXO/FXS card, I am only able to call out. Calling in gets no response from the system. Also, the call fails to show up on the call log.

Is there anywhere else I should be looking that might explain why the system doesn’t recognise an incoming call to port 4?

Thanks,

Gaoming

Any chance we can have some CLI output during a failed call?

Hi John,

Thanks for the inquiry.

Unfortunately, I am technologically ignorant, so I’m not sure which CLI output you are looking for. I can show you a screenshot of the call log for a few calls. I am attaching it here…

Imgur

Unfortunately, the failed calls in (where there is no response from the system) do not appear on the call log at all.

Please let me know if there is somewhere I should look for more detailed data, and I will be glad to display it.

Thanks,

Gaoming