Help chase down acoustic echo

Here is my system: I have 8 analog lines into 8 FXO ports on 2 TDM410P cards with MG2 hardware cancellers. FreePBX 14/SNG7 on a Core2 PC with 4GB RAM. No external SIP trunking. 12 Grandstream GXP 2130/2160 phones on the LAN. One Cisco 122 ATA with analog cordless phone

I am experiencing significant acoustic echoing. This holds for the Grandstreams and the ATA. The problem is slightly reduced when we turn the volume down on a specific phone. Everyone eventually turns the volume back up to hear a customer though. The delay of the echo varies from very little to about 500ms. The previous system had no echo at all (it was not asterisk) on the same lines. I have seen many posts on how to deal with this. I have tried turning the echo canceller off and on in DAHDI Config, tried echo training, same results. My ping results from PC to phone are around 25-35ms.

Anything else I should try to eliminate or reduce the echo?

MG2 is Software, so if you’re seeing MG2 you’re using software.

This is almost always solveable by running ‘fxotune’. See https://support.digium.com/community/s/article/how-to-basic-fxotune for more information.

This sort of echo is always introduced at the Analog->Digital gateway, which in your case is the TDM410P cards. Don’t bother looking anywhere else (and disregard the ATA, as that is another place where echo could be introduced, so get it working clearly on the SIP devices before you look further)

1 Like

fxotune is a good idea, but…

oslec > mg2. I’d give that a go. If it doesn’t work, but one of the hardware based echo cancellers. I’d recommend the VPMOCT032 module, it has superior performance to the VPMADT032, which is more in line with oslec.

I ran into a problem with EC on a Synway board - I configured oslec in the system and the hardware cancellers kicked in. Turned off the hardware cancellation and just used oslec and performance was restored.

Fxotune did the trick! Thanks so much, not sure how I missed it in my earlier research, but thanks again!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.