FreePBX | Register | Issues | Wiki | Portal | Support

Help a newbie troubleshoot!


(Dfinkle) #1

Hi everyone,

I’m new to all of this, but very interested in learning more about FreePBX and VoIP in general (much of my interest has been sparked by the users of this forum - thank you!). I’ve been curious about FreePBX and decided to give it a go getting it running on an old PC. I don’t want to start spending money on equipment and services until I get a good grasp on how it all works and I figured this would be a good way to start. I’m trying to get things up and running but need some help troubleshooting.

I downloaded the latest distro from FreePBX and installed it following the great videos from Crosstalk Solutions on YouTube. Everything seems to have gone great, installed with no apparent problems. I’m able to access the admin panel, make some basic configurations as advised in the Crosstalk videos, and run all of the updates. Everything looks good until I try to connect with softphone software and haven’t been successful yet. I get the errors “403 Forbidden” from Zoiper and “Account failed to enable” and “Unknown error. Contact your administrator” from X-lite. Not very helpful. I haven’t purchased any hardware yet to see if they will work.

The freepbx server is on a static IP. I can ping from the server to my PC and from my PC to the server. I can connect to the server from the pc using ssh/putty without issue. I have contacted ubiquiti and after some troubleshooting they concluded that there doesn’t appear to be any reason the router’s firewall would prevent the softphone from connecting. I have tried disabling the freepbx firewall entirely and the problem persists. I have also confirmed that the extension logon and password were correct.

Any advice on how I can continue to troubleshoot this? Thanks for your patience and any assistance you can provide!


(Dfinkle) #2

Just took a look at firewall.log - I don’t understand much, but there are a ton of entries stating “1549302002: Firewall-Monitoring - Auth failure from 192.168.XXX.XXX detected.” The IP referenced is that of my desktop pc where the softphone is installed.


(Itzik) #3

If you followed Crosstalks videos, I assume you created a ChanSIP extension, and by default ChanSIP is on port 5160.

If that’s the case, then you need to specify the port in the server address in your Softphone. (Domain = 192.168.??.??:5160)

Also, I understand from your post that you have firewall enabled. Did you allow traffic from your network?


(Dfinkle) #4

That was it! Thank you! As soon as I specified the port it worked with no problem.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.