Having problems installing free PBX

I’ve run into a problem where I’m know longer able to install free PBX, does anyone have any insight to what is going on? Below you will find a list of hardware I’ve tried and settings.

When I go to do the install like normal and I select the version/method (I’ve tried them all) and hit enter I get stuck on the blue splash screen that says sangoma at the bottom.

Example:
===> 1) Free PBX Advanced Installation
===> 2) Minimal Automated sangoma 7 Install (all space)
Blue splash screen hung

Free PBX version - Installed using/from a USB Key
SNG7-PBX16-64bit-2204-1
STABLE SNG7-PBX-64bit-2203-2

Motherboards (all BIOS’s are up to date) :

Asus H610M-A D4
Asus B660M-A D4
Asus H570-M Plus
Asus B460M-A

Processors:
Intel i5 12 gen
Intel i5 11 gen
Intel i5 10 gen

Storage:
WD1005FBYZ
SSDSC2KB480G8
WDS500G3XHC

Video Cards:
Asus GT730-SL-2GD5-BRK

NIC:
EXPI9301CTBLK

Settings I’ve tried:
vga=normal
nofb
nomodeset
video=vesafb:off

Any feedback would be appreciated.

Can someone confirm if the current FreePBX Distro found on the freepbx download page can still be installed directly on modern computer hardware?

Use the kernel argument ‘nomodeset’ with a terminal that can display 640x480 and 800x600 , can you access your virtual terminals at ctrl-alt-n after starting the install ?

Yes. It can. People are doing it all the time.

The FreePBX Distro is based on CentOS 7 and Rad Hat is ending CentOS, no more drives.

CentOS EOL Guidance
CentOS 8 - December 31, 2021
CentOS 7 - June 30, 2024

I was able to install FreePBX on an old H370M-M plus board no problem. The thing is if CentOS 7 is end of life in two year that means it will start showing up as an item that needs to be replaced on next year’s network security audits. I’m going to have to think about this one . . . . . . . . Fun times !

Run a search on this forum and you’ll find multiple threads discussing distro. I believe the latest is that the best candidate moving forward is Rocky Linux