Has it Blown up?

I have a Digium TDM410 with to extension modules and two line modules.

Following a thunderstorm when I try and dial out or in get busy.

Not wanting to play around with the system that was previously working I removed the card and set up a new fresh system. I can connect phones to the extension ports, get dial tones and can make and recieve internal calls.

I still can’t use the line ports, I’m fairly sure I have set it all up correctly, if I look at the output when I dial 9100 I get the following.
– Executing [[email protected]:22] Dial(“SIP/100-00000005”, “DAHDI/g0/100,300,Tt”) in new stack
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,src,dst,channel,dstchannel,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,eventextra,userfield) VALUES (‘CHAN_START’,{ ts ‘2013-08-11 13:52:27’ },’’,’’,’’,’’,’’,‘s’,‘from-pstn’,‘DAHDI/3-1’,’’,’’,’’,’’,’’,’’,3,’’,‘1376225547.13’,‘1376225547.12’,’’,’’,’’,’’)]
– Called DAHDI/g0/100
[2013-08-11 13:52:28] WARNING[2025]: chan_dahdi.c:5252 dahdi_train_ec: Unable to request echo training on channel 3: Invalid argument
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,src,dst,channel,dstchannel,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,eventextra,userfield) VALUES (‘ANSWER’,{ ts ‘2013-08-11 13:52:31’ },‘CID:100’,‘9100’,’’,’’,’’,‘9100’,‘from-pstn’,‘DAHDI/3-1’,’’,’’,’’,’’,‘AppDial’,’(Outgoing Line)’,3,’’,‘1376225547.13’,‘1376225547.12’,’’,’’,’’,’’)]
– DAHDI/3-1 answered SIP/100-00000005
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,src,dst,channel,dstchannel,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,eventextra,userfield) VALUES (‘ANSWER’,{ ts ‘2013-08-11 13:52:31’ },‘test’,‘100’,‘100’,’’,‘9100’,‘s’,‘macro-dialout-trunk’,‘SIP/100-00000005’,’’,’’,’’,’’,‘Dial’,‘DAHDI/g0/100,300,Tt’,3,’’,‘1376225547.12’,‘1376225547.12’,’’,’’,’’,’’)]
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,src,dst,channel,dstchannel,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,eventextra,userfield) VALUES (‘BRIDGE_START’,{ ts ‘2013-08-11 13:52:31’ },‘test’,‘100’,‘100’,’’,‘9100’,‘s’,‘macro-dialout-trunk’,‘SIP/100-00000005’,’’,’’,’’,’’,‘Dial’,‘DAHDI/g0/100,300,Tt’,3,’’,‘1376225547.12’,‘1376225547.12’,‘DAHDI/3-1’,’’,’’,’’)]
> [INSERT INTO cel (eventtype,eventtime,cid_name,cid_num,cid_ani,cid_rdnis,cid_dnid,exten,context,channame,src,dst,channel,dstchannel,appname,appdata,amaflags,accountcode,uniqueid,linkedid,peer,userdeftype,eventextra,userfield) VALUES (‘BRIDGE_END’,{ ts ‘2013-08-11 13:52:43’ },‘test’,‘100’,‘100’,’’,‘9100’,‘s’,‘macro-dialout-trunk’,‘SIP/100-00000005’,’’,’’,’’,’’,‘Dial’,‘DAHDI/g0/100,300,Tt’,3,’’,‘1376225547.12’,‘1376225547.12’,‘DAHDI/3-1’,’’,’’,’’)]
– Executing [[email protected]:1] Macro(“SIP/100-00000005”, “hangupcall,”) in new stack

If I look at dahdi_tool, it tells me that the 2 lines are active if they are connected. if I unplug them they go inactive.

When the system was in use only one of the lines was connected so I was hopefull that only one would be damaged but I am experiencing the same issue with both. Unfortunately I don’t have card that I know is working to swap and prove that this one if faulty.

Is there any more I should do before spending my money on a new card or modules?

Thanks Dave