Hangup after 1m30sec on incoming call

Hi all,

I am new to this forum.

These last days I have installed a Freepbx Stable hidden behind a firewall. Everything seems to be working fine : internal calls between extensions ok, calls to outside through sip trunk ok, incoming calls from sip trunk to internal Queue ok,

But I experience one problem : Incoming calls from sip trunk to a specific extension always hangup after exactly 90 seconds.

This does not seem related to the phone that handles the extension, because it happens exactly the same on different phones of different makes (Aastra, Philips).

Even more strange, if the inbound route is linked to a Queue, I have no premature hangup on this queue, even with only one extension as target for this queue. So this does not seem to be linked with the trunk settings.

If I make an internal call between 2 extensions that experience the premature hangup problem on inbound calls, everything’s ok : no hangup. So it really does not seem to be related to the phone settings.

Any idea? Where could I start, in order to find clues of what is happening?


Hello LaP,

I would recommend first posting a log file of this happening. Start your log, Then place the call in and wait for it to drop. Once the call has been dropped stop your log and then post the output here. This will give everyone a little more information to work with.

This smells like a firewall problem. Probably a NAT issue. What is your configuration for SIP Settings

DSL line with small router, nothing set up for inbound (port forwarding). For outbound, static NAT tcp/udp for all ports 5060-65534.

Second step, a pfSense router. Nothing set up for inbound (port forwarding). For outbound all ports statically NATed between the asterisk server (on the Lan) and the Wan of the pfSense.

On the asterisk server, which is on the lan : nat=YES, externip= the external ip of the first router

We tested with all the default dynamic nats on the routers, but experienced voice not entering. Voice could only go out. With all the static nat stuff, no voice is lost.

One detail I forgot on my first post : We use G729 codec (only, others not allowed) with licence bought recently from digium.


From what I remember, asterisk starts the call, then 1 ou 2 lines of log without much information (for me), then a call to macro “hangup”.

I’ll post you a full log here soon. Thanks for your help.

Who is your VOIP Provider?

Have you opened a trouble ticket with them?

Do you have sendrpid=yes in your trunk settings? If so, try removing it and then see if the problem goes away. If it does, let us know, and add a comment to this trouble ticket:


Problem solved.
It was a config problem on the VOIP Provider side. In fact, I do not really know which problem, but they solved it, telling me that have found the bug and fixed it.

Thanks to everybody here for helping