GV All Circuits are busy

AHHHHH! I used to use PBX in a Flash with Google Voice and no issues at all. I downloaded the latest FreePBX Distro, and GV Module 0.0.8 and all I get is “All Circuits are Busy Now” and when I call my GV number it still will go to my GV voice mail. (yes I checked all those settings) Softphones seem to work from extension to extension, but that’s it. Thinking maybe something was different with FreePBX vs PBX in a Flash, I reinstalled that as well with Asterisk 10 and GV 0.0.6 and I got the same result. The MAIN thing that has changed since last time I configured this is my ISP went from Comcast to Charter…however with Comcast I was plugged directly into their router. Charter does not allow this, so I am in a WAP/HUB, that has an WAN uplink to the Charter Modem. Not sure if that is the issue since I can still register externally and call extensions, but just trying to figure this out. IF you need logs, please tell me how to extract them. I am not heavily experienced in Linux.

Thank you

You should start over. Use Asterisk 11. and then install the module Motif, it’s in the online repo. Don’t bother with anything other than Asterisk 11 for Google Voice. and Don’t use that old google voice module, only use Motif

Well I had initially installed the FreePBX Distro. I selected Asterisk 11 during the setup. The only thing I didn’t use is the module Motif. I used the Google Voice Module 0.0.8. If I just remove that module and install Motif…might that work?

Thanks for the reply

Yes but you must have Asterisk 11 installed.

OKay…I am running version 11.4. I am pretty new to Linux, how do install that module from the repository using the CLI?

Thanks again for your assistance.

Make sure you have an inbound route set up, the lack of one will create this very issue.
Make sure all the correct ports are open on your router, make sure your new ISP is not blocking any of these ports.

5222 UDP
5060 UDP
10000 - 20000 UDP <- range does not need to be this large or on this particular range, but is the default range of ports.

I will have to check with my ISP but yes I have routes and ports. A lot of tutorials I have seen show that GV (Motif) under connectivity menu, but my FreePBX Distro didn’t have that and I have the latest distro. I dont know the repository path for the MOTIF module and I cant find it doing a search

I found the MOTIF module here http://mirror.freepbx.org/modules/release/contributed_modules/
I uninstalled GV 0.0.8 and installed this, did an amportal restart and everything worked instantly.


Now to see if I can get my voip phone to work =)

That is extremely old and may break. Please use the correct repository to use the most up-to-date version. Go to module admin and select “unsupported”. The one you downloaded was written over a year ago.