GUI password mysteriously changed

I have 2 freePBX boxes running over a VPN. I was working on them today and all of the sudden I couldn’t log into one of them. I’ve tried rebooting it, different browser, caps lock, etc. etc. No joy. It’s as if someone changed the password while I wasn’t looking.

Is there an easy way to change or lookup the gui password from the console?

Thanks :slight_smile:

That’s odd, do an ‘amportal a ?’ from CLI to see all FreePBX admin commands.

Running that command from the console doesn’t really tell me what I need.

Surely there’s a way to view/change/delete the gui user passwords from the console…??

If you unlock the gui you can go in and change the password.

The password is hashed in the DB, you can’t just change it from the shell.

I see this is updated in the wiki, I forgot you have to pass the session ID:

Sorry to sound so ignorant skyking. I’m just a stupid windows guy trying to learn something new. Could you possibly point me to some instructions for unlocking the gui?

Did you get this to work?

I got side tracked yesterday. Will work on it today and let you know.


Yes, it worked perfectly.

thanks again.