GUI ISSUES after update

I have about six pbx’s that can’t switch tabs or click on various buttons / tabs / elements.

Example: Link for Freepbx Admin will not work (does not ask for username and password as it should)
*** work around was session key, but most tabs still do not work

Example: none of the tabs work with in firewall module
Example: Extension page loads with no extensions showing

I compared it with a test VPS and I can’t reproduce it on any other machine. I do not see any obvious cause for this issue. The javascript error “Uncaught ReferenceError: moment is not defined” is the only thing I am seeing on every page that I do not see on other machines. Any ideas???

What we have done so far…

  • noted can’t switch tabs or click on various buttons / tabs / elements
    • fwconsole chown / restart httpd has no effect
    • refreshsignatures OK
    • framework
  • noted test machine has framework
    • installed updates
    • framework is now
    • still cannot reproduce issue even with
  • noted there are no module updates pending on customer server
  • noted there are no yum updates pending on customer server
  • some odd javascript errors in inspection console:
  • reinstalled framework
  • reinstalled sysadmin
  • compared installed module versions with those on my test PBX
  • no differences I can see
  • command history looks OK
  • web root / configs / tmp directory looks OK
  • apache logs look OK
  • tried a reboot

One thing I do see lacking. Tried another browser?

Tried another browser, computer and ISP… no luck

If anyone has the same issue, the solution is inside this jira:

Can you please login to cli and run

rm -rf /var/www/html/admin/assets/js/pbxlib_*

Install the latest framework module clear the browser cache and try to login again.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.