GUI hangs after adding a user

Hello everybody.
My PBX based on FreePBX latest distro (1.89.210.57-2) was working correctly in extensions mode.
Then I switched to User and Devices mode, and it was working.
I received a notice informing me I had to set “Dinamyc Hints” to be consistent with this mode.
Any Time I tried to swithch on the Dynamic hints option, the GUI hanged obliging me to restart the server (ssh was responsive).

I tried to remove all the users from the system and switch on the option.
This was successful.

But whenever I try to add an user, the GUI hangs again.
Last bunch of messages before GUI becomes unresponsive follow.

Any hint?

Thanks in advance

Carlo

[2012-Mar-04 14:55:08] [INFO] (bin/retrieve_conf:109) - found language dir fr for directory, not installed on system, skipping
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: ASTETCDIR = /etc/asterisk
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: ASTVARLIBDIR = /var/lib/asterisk
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: ASTSPOOLDIR = /var/spool/asterisk
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: ASTRUNDIR = /var/run/asterisk
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: ASTLOGDIR = /var/log/asterisk
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: CWINUSEBUSY = true
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: AMPMGRUSER = admin
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: AMPMGRPASS = amp111
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: AMPDBENGINE = mysql
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: AMPDBHOST = localhost
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: AMPDBNAME = asterisk
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: AMPDBUSER = freepbxuser
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: AMPDBPASS = fhTjkuytdgh
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: VMX_CONTEXT = from-internal
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: VMX_PRI = 1
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: VMX_TIMEDEST_CONTEXT =
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: VMX_TIMEDEST_EXT = dovm
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: VMX_TIMEDEST_PRI = 1
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: VMX_LOOPDEST_CONTEXT =
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: VMX_LOOPDEST_EXT = dovm
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1743) - Added to globals: VMX_LOOPDEST_PRI = 1
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1750) - Added to globals: MIXMON_DIR =
[2012-Mar-04 14:55:08] [INFO] (core/functions.inc.php:1754) - Added to globals: MIXMON_POST =
[[email protected] asterisk]#

Tried to make a fresh install and test the bug again.
Even in this case, as soon as the “Generate Dynamic Hints” is set, no user can be added without hanging the GUI.
Am I the sole user running Devices And Users mode?

This has been filed with Asterisk:

https://issues.asterisk.org/jira/browse/ASTERISK-19487

The corresponding FreePBX bug is #5646

We are waiting for feedback from Asterisk …