GUI fail after upgrade

Ran the script this morning, no errors… rebooted the server and then tried to run It prompts me to “please update your modules and reload asterisk by browsing to your server” and then the script just stops.

If I go to the browser and try to click the update settings button I get the response…
Error: Did not receive valid response from server
XHR response code: 0 XHR responseText: undefined jQuery status: timeout

In the background you can see the status of the webserver go to yellow/timeout and then subsequently red/offline… if I check the apache service itself it appears to be still running fine though.

Have tried rebooting and still no luck, the minute I click that update settings button everything comes to a screeching halt.

Have looked in freepbx.log and I see a few “fatal error updating freepbx_settings table”

Any ideas how I can bring this system back from the dead?


Mike <<<<<

what version were you on before you ran the upgrade scripts. Did you upgrade to 2.10 manually or use the upgrade scripts for the Distro.

The system was originally a clean install of (64-bit). No upgrades of any kind applied prior to


Mike <<<<<

It sounds like you ran the upgrade not the Your error is about the FreePBX Settings table. The assumes you are on a FreePBX 2.9 not 2.10. Can you verify which upgrade script you ran. Their are logs for each upgrade in /var/log/pbx/upgrade. Look at the time stamps.

Sat Mar 3 09:56:46 MST 2012 This appears to be a FreePBX Distro system as it has a FreePBX Distro Version of

Sat Mar 3 09:56:46 MST 2012 Your FreePBX Distro System is being upgraded to Please standby…


Mike <<<<<


Not sure than. Wonder if it is something weird with 2.10 modules. That error is not related to the Distro but FreePBX GUI.