GUI blank after upgrade

Hi

I have read thru the posts on this topic and i have tried many of the recommendations.

about my system

Installed from the distro

i am running 6.12.65-22 i upgraded the distro to this point.

I deleted cookies and browser history

when i run “amportal a ma list” i get

[[email protected] upgradescripts]# amportal a ma list

Fetching FreePBX settings with gen_amp_conf.php…

PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/bria/functions.inc/userman_hooks.php on line 0

when i run amportal a dbug

[[email protected] upgradescripts]# amportal a dbug

Fetching FreePBX settings with gen_amp_conf.php…

trying to run as user asterisk:

[FPBXDBUGDISABLE] already set to [0]

==> /var/log/asterisk/freepbx_dbug <==

2015-May-10 19:14:29 /var/www/html/admin/modules/pagingpro/functions.inc.php:0
[WARNING]: License check failed!

2015-May-10 19:15:01 /var/www/html/admin/modules/qxact_reports/functions.inc/import_queue_data.php:0
[WARNING]: No license for this product (PBXact) - make sure zend_loader.license_path is properly configured in your ini file!

2015-May-10 19:15:01 /var/www/html/admin/modules/qxact_reports/functions.inc/import_queue_data.php:0
[WARNING]: License check failed!

==> /var/log/httpd/error_log <==
[Sun May 10 19:09:45 2015] [error] [client 172.18.0.210] PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/bria/functions.inc/userman_hooks.php on line 0
[Sun May 10 19:09:45 2015] [error] [client 172.18.0.210] PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/bria/functions.inc/userman_hooks.php on line 0

Following the instructions in another post i tried rm -Rf /var/www/html/admin/modules/cxpanel

This did not resolve the problem.

When updating the disrto the following appears in the beginning of the update

PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/cxpanel/lib/PHPMailer/class.phpmailer.php on line 0

Here is the /var/log/httpd/error_log

==> /var/log/httpd/error_log <==
[Sun May 10 18:33:09 2015] [error] [client 172.18.0.210] PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/cxpanel/lib/PHPMailer/class.phpmailer.php on line 0
[Sun May 10 18:49:16 2015] [notice] caught SIGTERM, shutting down
[Sun May 10 18:49:17 2015] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sun May 10 18:49:17 2015] [notice] Digest: generating secret for digest authentication …
[Sun May 10 18:49:17 2015] [notice] Digest: done
[Sun May 10 18:49:17 2015] [notice] Apache/2.2.15 (Unix) DAV/2 PHP/5.3.28 configured – resuming normal operations
[Sun May 10 18:49:30 2015] [error] [client 172.18.0.210] PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/cxpanel/lib/PHPMailer/class.phpmailer.php on line 0
[Sun May 10 18:49:58 2015] [error] [client 172.18.0.210] PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/cxpanel/lib/PHPMailer/class.phpmailer.php on line 0
[Sun May 10 18:49:59 2015] [error] [client 172.18.0.210] PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/cxpanel/lib/PHPMailer/class.phpmailer.php on line 0
[Sun May 10 18:49:59 2015] [error] [client 172.18.0.210] File does not exist: /var/www/html/favicon.ico, referer: http://172.25.200.200/admin/config.php

Thank you in advance for any help, i am not having any luck finding this problem.

Chris

Update

I found module bria also reporting that PHP Fatal error: Class ‘FreePBX’ not found so i ran

rm -Rf /var/www/html/admin/modules/bria

now i have a GUI back, however it is the old GUI.

i attempted to use the “module admin” to update and download

when i press “apply config” i get

Reload failed because retrieve_conf encountered an error: 255

click here for more info
1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

After reading other posts i ran amportal a ma upgradeall

i get the following (please see below)

It looks like the upgrade did not work.

Any help greatly appreciated.

Chris

[[email protected] classes]# amportal a ma upgradeall

Fetching FreePBX settings with gen_amp_conf.php…

no repos specified, using: [standard,extended,unsupported,commercial] from last GUI settings

Upgrading: sipstation, parkpro, vmnotify, ringgroups, fax, faxpro, voicemail, directory, queues, xmpp, endpoint, qxact_reports, sipsettings, restart, conferencespro, cdr, cos, sysadmin, conferences, pagingpro, parking, customappsreg, timeconditions, featurecodeadmin, paging, calllimit, dashboard, callerid, vmblast, core, backup, voicemail_report, callrecording
Upgrading sipstation…
Downloading 0 of 596770 (0%) --2015-05-10 22:08:39-- http://mirror1.freepbx.org/modules/packages/sipstation/sipstation-12.0.8.2.tgz?installid=e8b23140fad81d64eaadbbd31668bea0
Resolving mirror1.freepbx.org… 162.253.134.144
Connecting to mirror1.freepbx.org|162.253.134.144|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 596770 (583K) [application/octet-stream]
Saving to: “/var/www/html/admin/modules/_cache/sipstation-12.0.8.2.tgz”

100%[=========================================================================================>] 596,770 1.33M/s in 0.4s

2015-05-10 22:08:39 (1.33 MB/s) - “/var/www/html/admin/modules/_cache/sipstation-12.0.8.2.tgz” saved [596770/596770]

Downloading 596770 of 596770 (100%)

Untaring…Done
Module sipstation successfully downloaded
The following error(s) occured:

  • Module FreePBX Framework is required, but yours is disabled because it needs to be upgraded. Please upgrade FreePBX Framework first, and then try again.
  • Module User Management is required, but yours is disabled because it needs to be upgraded. Please upgrade User Management first, and then try again.
  • FreePBX version 12.0.1beta24 or higher is required, you have 12.0.0alpha1
    [[email protected] classes]#

fixed now, i now get the correct GUI