Grandstream HT813 as VoiP Gateway

Dear friends, please I would like to know if is there a guide on how to Setup Grandstream HT813 as a VoiP Gateway for my FXO line. I will need to receive and make calls using this trunk. I would like to know about the possibility to setup a DID number as i can direct this call to a specific internal extension.
Many thanks

A quick check through the Forum history pulled this up.

Many thanks for answering. In this topic they onluy discuss some differences between SPA3102 and HT813 bot nothing concrete… I could download HT 813 manual and I’m setting up with my Freepbx. If i get success i will publish a guide. Have a nice day

Here are notes and screenshots from a similar unit. This was for a doorphone connection, which was FXO as well. Hope it helps.

snip —
Additional Notes From Another User

These instructions do work setting up the FXO port of a Grandstream HT-503. You do end up with a working system. However, as the author points out, Caller ID has not been addressed. And in this configuration Caller ID will not work at all. The mistake is configuring an extension to receive inbound calls. Do not do this. Only configure the trunk. Trunks are intended for both inbound and outbound traffic. If you send inbound calls through an extension, the Caller ID will be set to the name and number of that extension, which is what you want for an FXS port but not an FXO port. Some configuration points I discovered:

Make sure the trunk name on both the General Page and the SIP Settings page of the trunk configuration matches your User ID on the Unconditional Call Forward setting and the SIP User ID and Authenticate ID on the FXO page of the HT-503.

I am unclear how much the port number of the Unconditional Call Forward setting matters. Once I removed the extensions, I reset one of my HT-503s from port 5060 to port 5062 thinking this was important. But I forgot the other HT-503, leaving it at 5060. However, both HT-503s continued to work for inbound calls. I suspect once you have only a single destination for a particular username, FreePBX just figures things out. However, for consistency sake I have set both ports to 5062.

The Outbound section of SIP Settings on the trunk is not configured at all.

Note the HTML of the FXO page on the HT-503 sometimes does not maintain the Authenticate Password setting if you make changes on that page. If you have problems dialing out try resetting the password on that page.

Be sure to set the PSTN Ring Thru FXS setting to “No” on the FXO page of the HT-503. This was reiterated by Grandstream tech support. The FXO and FXS ports are two different things in this application.

Multiple sources say that Caller ID information is transmitted between the first and second ring on most PSTN systems. This means you need to set the
Number of Rings on the HT-503 to at least two. This is the case on my two analog Comcast PSTN lines.
Set “SIP Registration” to “No” in the HT-503 FXO port. There is nothing to register. Everything still works. If you look at the SIP report or ‘asterisk -rx “sip show peers”’ you’ll see that the trunks are “unmonitored.” Once you have only the trunk setup, the first page of the HT-503 will no longer show “Registered” for the FXO port. If you leave registration on, you’ll see warnings logged about registration failed – peer is not supposed to register.

The Peer Details section above is a bit hard to read. Host is the IP address of the HT-503. Username is what you need to match across the trunk and HT-503. Here is mine:

----- snip

Thanks a bunch ! It really has helped me !

Really glad. Quick question if you don’t mind: Did you get Caller ID working? In that tutorial they said it didn’t work, but it was from a while ago.

It´s working here ! I´m in Brazil and the only change i have made, differently from this guide was: Setting up caller id to DTMF Brazil and i have changed de time that the call is directed to Voip. It´s important to take some seconds (like 2 o 3 rings), as Caller id can have enought time to keep the information from phone company and sends it to VoIP system.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.