Grandstream GXW4108 drops call at 15 minutes

This apparently has been going on for a long time and the customer just happened to mention it. The FBPX and the Grandstream are on the same network, on the same switch. Here is the peer programming from the trunk


I do not have remote access to this site, but I will be going there to try to see what is going on. Meanwhile if anyone has any ideas of things to try I am open to any suggestions.

Before you go, search the forum for ‘15 minutes’ and ‘30 minutes’. Chances are, the intervening router is timing the NAT out (or something similar) and killing the call.

There are a couple of ways to deal with it, IIRC. One is to set the phone/extension up so that you ‘refresh’ the connection every 10 minutes or so. The other involves changing the router config to time the calls out at a longer interval.

Once again, this is based on memory, but there are LOTS of people that have dealt with this over time, so I’m sure you’ll find a solution

No router between the gateway and the pbx. I will probably run tcpdump to see

There are also timers in the extension that you might want to check, if there’s no significant equipment in the path. I’m trying to remember, but it seems to me that there’s a registration setting (?) that you might have to turn off to get the timers to stop deregistering your phones?

BTW - your trunk programming isn’t going to have any effect on your local phone registrations. Extensions are handled outside the trunk setup unless they are registering through an external connection, like a firewall or a router…

I found where someone used session-timers=refuse in the sip setting. I’ll look at the timers for the extensions also. Thanks Dave

IMO there are 3 likely possibilities:

  1. Timer issue with the extensions.
  2. Timer issue with the GXW.
  3. Problem on the FXO side.

Rule out (1) by confirming that calls between extensions do not drop at 15 minutes.
(3) should not be an issue if GXW is connected to copper pairs from the central office. If it is connected to a cable MTA, fiber ONT, etc., please provide details.

Assuming (2), you have two options: Fix it so timers work properly, or turn the timers off. You could do both sets of changes, in the hope that at least one will fix the problem.

To turn off the timers at the GXW end, confirm that Caller Request Timer, Callee Request Timer and Force Timer are all set to No. At the PBX, session-timers=refuse as you have already noted.

For proper timer operation at the GXW, confirm that STUN Server is Blank, Use Random Port is No and NAT traversal is No. At the PBX, in Asterisk SIP Settings, confirm that External Address and Local Networks are properly set. Restart Asterisk if you change these.

Thanks Stewart,

I checked all the settings in the Grandstream as you suggested and they were as you said. So moved on to the PBX, Set the session timers = refuse in the sip settings and also noticed that the external IP address in the Chan Sip settings was incorrect, corrected that although the system doesn’t use SIP trunks. The “POTS” lines are Lines provided from a gateway from the Cable company (Charter). In speaking to the users the 15 minute cutoff appears to be random, and not limited to direction. There is only one trunk between the grandstream and the PBX, so I am thinking that there might be something amiss with the Chrter Gateway.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.