Grandstream GXP2100 will not load firmware

Have the new paid EPM installed but I don’t think the Grandstream phones have ever successfully pulled a firmware file (via TFTP). In the GUI it’s set to always look for new firmware, though in the cfg file it says it only checks weekly. In the messages file I see it attempting to pull a bunch of non-existent files


but never the one file that it needs (I think)


I checked both the MAC.cfg and the cfgMAC files and while the firmware path is mention in the cfgMAC file it only mentions the directory and not the specific file name.

Relevant numbers

the phone shows
Software Version

don’t know which of these corresponds to the firmware level listed in the EPM, which is

PBX Firmware: 10.13.66-16

You would need to talk with Grandstream on that. If the phone is not requesting the file we cant give it the file.

IN the firmware path we do not define the file name. The phone does that. We just give it the relative path.

Have you tried to use http to update it

I think I was having the same problem you were - It’s funny - if ANYTHING ever came easy I think I would keel over from shock.

Here is what I think the problem is and how I fixed it:

We use TFTP to provision our phones with DHCP option 66 pointing to our FreePBX boxes and Endpoint Manager - I think this is the same thing you are doing.

I am only using the 2135 and 2170 so perhaps this will not work for the 2100 - I don’t know because I only have 2135’s and 2170’s.

When endpoint manager configures the phones, and then you look at the phone here is what ends up in the Firmware Server Path:


But this does not work - it never pulls the firmware from this folder even though it’s right there ready to be pulled.

If you go into Basefile Edit and look at the model you are trying to fix and look at # Firmware Server Path - P192 you will see “underscore-firmware_” which is a replacement value that gives you the above string.

Edit the line and just put the IP address of your FreePBX box and nothing else - in my case

Re-generate the configs, and then finally copy the firmware files into the root of tftpboot - in my case gxp2135fw.bin and gxp2170fw.bin - they will be in /tftpboot/grandstream/1 if you used firmware slot 1.

Finally, make the phones reboot and take a fresh config (you make have to default them). and they should finally take updated firmware.

I am guessing Grandstream changed something that broke this since the generated line is actually correct - the files are there - but the phones NEVER touch them.

this did not work for us, but i am still investigating why.

There is a GS bug that was recently fixed:

Upgrade EPM to edge, rebuild and reprovision.