Grandstream 2135 TLS

Running the latest version of FreePBX with all module and system updates applied. - Using PJSip

Running the latest Granstream stable firmware as well.

I have configured TLS and SRTP as shown in this guide:

Using a LE Cert - however using the “default” cert doesn’t seem to help.

On the phone, I have set:

SIP Transport = TLS
SRTP Mode = Enabled and Enforced

Other than that, everything is factory.

Can’t get the phone to register with the PBX.

Thanks for your help! :slight_smile:

I registered a GXP phone using pjsip-TLS just yesterday. Customer was using the default self-signed cert, enabled TLS in Asterisk SIP Settings, and configured the phone to register to the TLS port defined in Asterisk SIP Settings. When making changes to port bindings, you must restart Asterisk.

Thank you so much for your help!

I have just restarted the system. What is the best way to restart Asterisk in the future?

1 Like

Generally, we use “Core Restart When Convenient”

More info in the link

Look at Lorne’s post below for the supported method.

In FreePBX, the supported method of restarting Asterisk and all most other call handling daemons is:

fwconsole restart

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.