Grandstream 2100 Image Management

I recently updated my EPM, and it has the new image management feature. I am trying to set this up for the GXP2100 phones, which I had previously accomplished by editing the basefile values myself, with a base64 image in a idle_screen.xml file.

I was excited that I didn’t have to mess with that, and a new system was in place to do exactly that. On top of that, the phones I use are tested/supported. Unfortunately, I can’t get it to work.

I have uploaded several images, including jpgs, pngs, and even a file direct from Grandstream that is the exact size type and format needed. It still will not show up on the phones.

I noticed in the /tftboot directory there are 2 folders, “originals” and “formatted”. Is there a script I need to run to have EPM convert files for me? Or am I missing something completely.

Shamless bump to see if anyone has an answer or has worked with this.

Update your EPM to the latest. it should be resolved.

I have the latest version installed, and I have spent the morning rebuilding my own extension profile over and over trying different files and formats. Nothing coming up on the phones. I have been watching the tftpboot/images/ folder as I have been trying different things, and there never is an image made in the /converted/ folder. I dont know if that helps or not.

Also, when I do choose an image, i get a blank spot where the Grandstream image should be, so it is putting something in that XML file (just not the base64 of the bitmap like it should).

Still nothing happening after the update to .9 over the weekend (even though it was specifically mentioned in the changelog).

Basically, the profile .xml files in /tftpboot (/tftpboot/grandstream-gxp2100-profilename.xml) have a section that looks like this:

5 17

It should look like this:

/app/resource/logo/gs_logo.bmp 17 26


Qk1eAwAAAAAAAD4AAAAoAAAAewAAADIAAAABAAEAAAAAACADAAAAAAAAAAAAAA AAAAAAAAAAAAAAAP///wD////////////////////g////////////////////4P///////////////////+D////////////////////g////////////////////4P////////////// /////+D////////////////////g////////////////////4P///////////////////+D////////////////////g////////////////////4P///////////////////+D////////////////////g///// ///////////////4P///////////////////+D////////////////////g///z4N/ggA/gfB4OD///4P//+cDc4IP/4HjkhB///+D///yB+MCD/+Bw/wQf///g ///+AfBBg//gcAYEH///4P///wPgAYP/4HCEDB///+D///4H4AGD/+BwjBwf///g///+A+DDg//geIwkH///4P///Anx44P/4H weCA///+D///gc8+OD/+B///wf///g///wHn//g/8AH///H///4P///////////////////+D////////////////////g////////////////////4P///////////////////+ D////////////////////g////////////////////4P///////////////////+D////////////////////g////////////////////4P///////////////////+D////////////////////g//////////// ////////4P///////////////////+D////////////////////g////////////////////4P///////////////////+D////////////////////g////////////////////4P///////////////////+D/ ///////////////////g////////////////////4P///////////////////+D////////////////////g////////////////////4A== 5 17

Both of these examples are taken from the GS documentation here:

I can obviously base64 encode a bitmap and stick it in there, but every time I make a change to the hotkeys or BLF keys, or EPM updates, I would have to SSH in and fix it manually.

I inserted the above base64 encoded example into my phone just now and it worked (showing a test XML logo), but as I suspected when I made a change to that profile and hit save, it reverted the file.

Hope I’m helping!

Do you have ImageMagick installed. I know on some installs it was missing.

yum install ImageMagick


Installed about 12 dependencies with it, but all fine and good. Then rebuilt my profile and rebooted my phone, logo appears!

I find it odd that this install didn’t have it, but that was the key! Thanks for the help, and thanks for all the great work!

Hopefully this thread can help others as well.

It was missing on Centos 6.3 and 6.4 installs. It use to be included in base install but somehow that changed. The latest upgrade script for the Distro installs it now.