GPG upgrade error on all modules in ver.


I’m currently automating an upgrade script for multiple servers in amazon. They are all started from the same AMI(Image), 100% identical.

Last week I could run my upgrade script without any problems. Since then I haven’t done any changes to the script but from the start of this week I get

- File Integrity failed for /var/www/html/admin/modules/_cache/packagenames.gpg - aborting

on every module I do changes to with amportal or through web gui.

The GPG breaks after running

All the 5.211.65.x, 10.13.66-x versions has no problems with upgrading/downloading modules with amportal/fwconsole.

This seems to only exist in 6.12.65-x.

All of this leads me to believe that something must have been changed by the FreePBX folks during last friday.

Either the has been modified lately or something wrong with all the hosted ver. 6.12.65-x GPG files.


What version of freepbx in both cases?

1 Like

Hi Andrew,

The main issue starts at version 6.12.65-20. Then I tried to upgrade one more version to 6.12.65-21, to see if the problem persisted, and it did.

So if you’re going to look into it, then focus on 6.12.65-20.

I hope that was the information you needed?


No that is not the information I need. The GPG checks have nothing to do with Distro versions. EG even though you think the error is with 6.12.65-20 it’s absolutely not.

Please give me the freepbx versions between the two systems

1 Like

I tried to search online about how to find the FreePBX version and all the results told me the version was read out from those numbers.

On the FreePBX server GUI interface on the bottom I can read these numbers FreePBX, the module framework shows the same version too.

This is equal for both 6.12.65-20 and 6.12.65-21. I guess if I would continue upgrading it would keep the same FreePBX version because the new framework can’t be downloaded because of the GPG error.

I didn’t have access to check the servers for this information from home last night, considering I’m 7 hours ahead of you.

Hope I’ve given the sufficient version numbers this time.


Freepbx 2.11 does not use the gpg system. Something is amiss with what you are telling us.

1 Like

So if it doesn’t support gpg system then where does those error messages appear from? It’s amportal giving these messages, if for example you try to download a new version of any module. This makes no sense to me.

Could I have given you the wrong FreePBX version? It’s not the one showing on the bottom of the graphical administration page, down by the logos? I also checked the framework, showing the exact same version as on the graphical administration page.

From what version does FreePBX start to use gpg then?

Framework 2.11 will never be able to read a gpg file because it doesnt have the gpg libraries.

12+ uses gpg. You are telling me that in module admin Framework says

1 Like

Yes the framework module says, while the /etc/schmooze/pbx-version file says 6.12.65-20.

Please separate the pbx-version and framework version in your mind. Let’s focus on FreePBX only.

Run these commands:

user asterisk;
select * from admin where `variable` = 'version';
1 Like

Could be related to the issue I experienced updating from the distro version 5.
Basically it downloaded .gpg files which it couldn’t handle.

I posted in the comments:

1 Like


I’m totally certain that the gui was showing version and that the framework is matching. I wont be able to run the SQL query to retrieve versions numbers before Monday, when I’m at work.


Thanks for posting that comment on the FreePBX-Distro-5.211.65 page, I’m certainly going to look into this.

@joellinn actually helped nail the issue down. This is now resolved on the mirror server.

1 Like

That’s great, you’ve all been really helpful :slightly_smiling: