Got SIP response 482 "Looping Request"

Hi all,

I configured CiscoSPA232D ATA with DID number and connected it to the fax machine. At PBX I created extension with the same DID number and inbound route with the same DID number. ATA registered to the PBX. When I was creating Inbound route I checked Detect Faxes and chose my previously configured extension as a Fax Destination. I had to configure also destination at the end and I chose the same extension. When I tried to call my DID number from outisde I got Got SIP response 482 "Looping Request. When I delete Fax Destination extension the DID rings but the Fax is not enabled. I want to test t.38. fax. Please for help.

Kind regards

We use a similar device on our fax machines.

The inbound route is configured w/o fax detection and only rings the extension. This causes the fax to receive the call and auto-answer (make sure this is turned on).

Please share screenshots of the configs and an asterisk CLI output of the call (asterisk -Rvvvvvvvvvv from Linux CLI); you can use and if you are too new to the forum to attach/etc. If you cannot post links, put the literal “DOT” instead of “.” (eg wwwDOTpastebinDOTcom) and we’ll figure out the rest.

Hi, thank you for your reply. Just to know I installed both Elastix and FreePBX in order to test them and compare, but unfortunately I started with Elastix :frowning:
Do you want to from me to post screenshots here via email or directly to the forum? Besided output of call of asterisk and trunk config , do you need some additional configs? Thanks for help I appreciate that very much.

Kind regards

Elastix has their own forum, I suggest going there for help. While their product is based on FreePBX, they modify it in a way that isn’t supported here.

The configs to post are the inbound route, extension, and fax destination. These and the call log would help.

I realised what is happening but I can not solve the problem, so I need help. When incoming call comes it matches the inbound route and then inbounde route forwards call to the corresponding extension. After that the error comes up "Got SIP response 482 “Looping Request (e.g. no next hop in Route or R-URI: P-CSCF FRA)”. This is because PBX first send invite to extension and after that it sends another invite again back to the trunk. This invite to trunk is making problems.Provider after few invites recgonize loop and send back 482 response. Why is PBX sending call again to trunk the trunk instead directly to the extension?

Trunk config


Inbounde route is matched wiith DID number, option detect fax is enabled and destination is set to 800. At the end destination is also set to 800 as can not be submitted without setting destination.

Disable detect fax; your fax machine will do that when it rings (remember to set auto answer on the fax). The IR should only ring the extension. At that point, your adapter will pick up the call, and when it converts the signal to the analog signal, the fax will take over. We use this config on all of our faxes.

I don’t know why your trunk is getting involved after the call answers; it shouldn’t be.

The problem is not just with the fax. If I match inbound route for example with IVR and then when you press some digit call is forwarded to extension for example 600. The same error happens. I thought that would be easier to explain with fax instead with IVR. Thank you for fax advice it is very useful. Do you know maybe now what is the problem with context and why my PBX is not sending call to extension 600 but back to trunk which causes loop and 482 response? I am really stuck I tried everything thats on the forum, but without success.


This sounds like a fundamental setup issue either with your provider, your
network, or elastix. Use the elastix forum for further assistance.

Ok, I did the same configuration on another server with FreePBX. And I have exactly the same problem. Can you help me to solve it?

Kind regards

Okay, then please post the Asterisk CLI output of the call so we can find out what’s looping.

The clue is your VSP is rejecting the call with a 428

check your usage of


with the VSP.

@dicko It’s 482, Dyslexicko :stuck_out_tongue:

oops :wink: , "never mind . . . "

It works when I set sendrpid=no in trunk configuration ! I will definetly use from now FreePBX as I have support. Thank you, I rembeber that I put sendrpid=yes because when is set to no, outgoing calls from DID number have callerid as my trunk username, can I change it?

Kind regards

I have deleted fromuser=xxxxxx option from trunk config and everything works now. Thank you for the support.